php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67784 PHP website links broken
Submitted: 2014-08-05 17:16 UTC Modified: 2014-08-14 18:30 UTC
From: dave at stalwartcontrols dot com Assigned: danbrown (profile)
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
 [2014-08-05 17:16 UTC] dave at stalwartcontrols dot com
Description:
------------
I was doing some research into hardening PHP at http://ca3.php.net/
<http://ca3.php.net/contact.php> and found that when I click on the
buttons that come up under the search box the URL was unfinished.

For example, if you type 'exec' and then select the button under the search
box with your mouse, it will take you to
-  http://ca3.php.net/manual/en/function.exec

But if you type 'exec' and then hit <enter> you end up at the right location
-  http://ca3.php.net/manual/en/function.exec.php

Also, the Downloads, Get Involved, and Help buttons in the main menu are also missing '.php' from the address


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-08-13 09:03 UTC] ab@php.net
-Package: Unknown/Other Function +Package: Systems problem -Operating System: Windows 8 Pro +Operating System: any
 [2014-08-13 09:03 UTC] ab@php.net
For me I can't even reach the ca3. mirror, so looks more like a DNS issue.
 [2014-08-13 20:21 UTC] bjori@php.net
-Status: Open +Status: Not a bug
 [2014-08-13 20:21 UTC] bjori@php.net
The mirror has been disabled because it doesn't work properly.

Please use "www" instead of "ca3"
 [2014-08-14 16:37 UTC] danbrown@php.net
-Status: Not a bug +Status: Closed -Assigned To: +Assigned To: danbrown
 [2014-08-14 16:37 UTC] danbrown@php.net
Hannes (bjori) disabled this mirror because of a misconfigured error handler, but the maintainers weren't notified.  They were made aware yesterday and repaired it immediately, and everything should once again be in working order.
 [2014-08-14 18:08 UTC] bjori@php.net
That is not true Daniel: http://markmail.org/message/7re2p4ztsp64s7gl (see the CC)

I did ask them to fix it when I disabled the mirror.
 [2014-08-14 18:30 UTC] danbrown@php.net
I stand corrected.  Sorry about that.  For whatever reason, the messages - indeed, the entire thread - never reached me.  I presumed it was just a minor oversight in forgetting to email them.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 17:01:28 2024 UTC