php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67765 Bundled Windows version missing libraries
Submitted: 2014-08-05 14:42 UTC Modified: 2014-08-13 14:11 UTC
From: anrdaemon at freemail dot ru Assigned: ab@php.net (profile)
Status: Closed Package: rrd (PECL)
PHP Version: 5.3.28 OS: Win32
Private report: No CVE-ID: None
 [2014-08-05 14:42 UTC] anrdaemon at freemail dot ru
Description:
------------
ZIP archive provided for PHP 5.3 is missing gobject-2.dll at least.

Test script:
---------------
When trying to start PHP script with rrd extansion enabled, system error message appears.

---------------------------
php.exe - Не удалось найти компонент
---------------------------
Приложению не удалось запуститься, поскольку gobject-2.dll не был найден. Повторная установка приложения может исправить эту проблему. 
---------------------------
ОК   
---------------------------



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-08-06 14:40 UTC] koubel@php.net
-Status: Open +Status: Feedback
 [2014-08-06 14:40 UTC] koubel@php.net
Windows support for rrd was added by some other core php developer. I have no access for any windows environment for compiling and testing ext, sorry.

But mentioned gobject-2.dll ins't presented in any zip from current release in http://windows.php.net/downloads/pecl/releases/rrd/1.1.3, so I don't know if it's really problem of rrd ext for windows. 

Message about gobject-2.dll can be complaining from another badly installed php extension.

1.) verify if your configuration of php is correct e.g. from shell:
$ php -i 
2.) Try to simple test script e.g. only with the http://php.net/manual/en/function.rrd-info.php call.
3.) Try to test previous simple script with the current supported php versions - 5.4, 5.5
 [2014-08-06 15:49 UTC] anrdaemon at freemail dot ru
$ cygcheck ext/php_rrd.dll
C:\usr\sbin\php-win32\ext\php_rrd.dll
  C:\usr\sbin\php-win32\php5ts.dll
    C:\WINDOWS\system32\ADVAPI32.dll
      C:\WINDOWS\system32\KERNEL32.dll
        C:\WINDOWS\system32\ntdll.dll
      C:\WINDOWS\system32\RPCRT4.dll
        C:\WINDOWS\system32\Secur32.dll
    C:\WINDOWS\system32\WS2_32.dll
      C:\WINDOWS\system32\msvcrt.dll
      C:\WINDOWS\system32\WS2HELP.dll
    C:\WINDOWS\system32\ODBC32.dll
      C:\WINDOWS\system32\COMCTL32.dll
        C:\WINDOWS\system32\GDI32.dll
          C:\WINDOWS\system32\USER32.dll
      C:\WINDOWS\system32\comdlg32.dll
        C:\WINDOWS\system32\SHELL32.dll
          C:\WINDOWS\system32\SHLWAPI.dll
    C:\WINDOWS\system32\ole32.dll
    C:\WINDOWS\system32\DNSAPI.dll
    C:\WINDOWS\system32\MSVCR90.dll
  C:\usr\sbin\php-win32\rrdlib.dll
    C:\usr\sbin\php-win32\cairo.dll
      C:\usr\sbin\php-win32\fontconfig.dll
        C:\usr\sbin\php-win32\expat.dll
      C:\usr\sbin\php-win32\pixman-1.dll
      C:\WINDOWS\system32\MSIMG32.dll
    C:\usr\sbin\php-win32\pango-1.dll
cygcheck: track_down: could not find gobject-2.dll

      C:\usr\sbin\php-win32\gmodule-2.dll
        C:\usr\sbin\php-win32\glib-2.dll
          C:\WINDOWS\system32\WINMM.dll
    C:\usr\sbin\php-win32\pangocairo-1.dll
cygcheck: track_down: could not find gobject-2.dll

      C:\usr\sbin\php-win32\pangowin32-1.dll
        C:\WINDOWS\system32\USP10.dll
cygcheck: track_down: could not find gobject-2.dll

      C:\usr\sbin\php-win32\pangoft2-1.dll
cygcheck: track_down: could not find gobject-2.dll

cygcheck: track_down: could not find gobject-2.dll
 [2014-08-06 16:06 UTC] anrdaemon at freemail dot ru
As I said, it is only reproducible, if I do

  dl("php_rrd")

in my code. So, I'm _fairly_ certain, that this is an incomplete build of associated libraries. Which cygcheck cleraly shows as such.
I didn't said you are at fault for not providing them, as this is clearly a packaging error. But having no way to recompile the library and all dependencies myself, I have to ask for help...
 [2014-08-07 08:07 UTC] koubel@php.net
-Status: Feedback +Status: Open -Assigned To: +Assigned To: ab@php.net
 [2014-08-07 08:07 UTC] koubel@php.net
OK, I assign to the ab for checking, because he added the windows support in the https://bugs.php.net/bug.php?id=67315
 [2014-08-13 13:52 UTC] ab@php.net
-Status: Assigned +Status: Closed
 [2014-08-13 13:52 UTC] ab@php.net
Hi,

please get the missing DLL from http://windows.php.net/downloads/php-sdk/deps/vc9/x86/glib-2.34.3-vc9-x86.zip . Yeah, that's my miss as we only carry the dll required by the core and also don't copy them into pecl packages. So looks like core required some glib DLLs, but not all of them.

We're currently working on https://github.com/FriendsOfPHP/pickle which will fetch all the dependency dll automatically, so stay tuned. I gonna add the missing DLL to the package by hand for now.

Thanks
 [2014-08-13 14:11 UTC] ab@php.net
Added the missing dll to the packages yet, so you can just redownload it.
 [2014-08-13 15:44 UTC] anrdaemon at freemail dot ru
Thanks, that solved the loading issue.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jun 26 04:01:26 2019 UTC