php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67517 Please change license (move away from PHP license)
Submitted: 2014-06-25 18:43 UTC Modified: 2014-06-27 05:53 UTC
From: math dot parent at gmail dot com Assigned:
Status: Not a bug Package: memcache (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2014-06-25 18:43 UTC] math dot parent at gmail dot com
Description:
------------
Current license is "PHP". This license can't be used by anything but PHP itself.

Can you change the license to something else (Expat is a good candidate, or BSD-2-clause)?

Regards

More info:
- https://ftp-master.debian.org/REJECT-FAQ.html (#3)
- Expat: http://www.jclark.com/xml/copying.txt
- http://spdx.org/licenses/BSD-2-Clause


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-06-26 11:16 UTC] pajoye@php.net
-Status: Open +Status: Not a bug
 [2014-06-26 11:16 UTC] pajoye@php.net
I do not see a remotely valid reason to change the license. The PHP
License is totally valid for extensions as long as it is released
under pecl.php.net.
 [2014-06-27 05:53 UTC] math dot parent at gmail dot com
IANAL, but current copyright file claims that the code is owned by the PHP group, and actual files says something else. This is at least false claim, and otherwise not redistribuable.

The other reason being that memcache will be shortly removed from Debian.

Ref: https://lists.debian.org/debian-devel/2014/06/msg00493.html
https://bugs.debian.org/752534
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Dec 10 10:04:15 2022 UTC