php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67511 Broken build against 5.6.0RC1
Submitted: 2014-06-25 08:47 UTC Modified: 2015-05-16 13:25 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: remi@php.net Assigned: cmb (profile)
Status: Duplicate Package: hidef (PECL)
PHP Version: 5.6.0RC1 OS: irrevelant
Private report: No CVE-ID: None
 [2014-06-25 08:47 UTC] remi@php.net
Description:
------------
From UPGRADIONG.INTERNALS

  l. Removal of IS_CONSTANT_ARRAY and IS_CONSTANT_INDEX hack

  These two #defines disappeared. Instead we have now IS_CONSTANT_AST which
  covers also the functionality IS_CONSTANT_ARRAY bid and furthermore the
  hack for marking zvals as constant index with IS_CONSTANT_INDEX is now
  superfluous and so removed.
  Please note that IS_CONSTANT_AST now has the same value than
  IS_CONSTANT_ARRAY had.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-05-16 13:25 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2015-05-16 13:25 UTC] cmb@php.net
This issue has been reported again as bug #69235. I'm marking this
report as duplicate, because the other report has a patch
attached.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 06:01:26 2019 UTC