php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67510 openssl can't be enabled on php windows.
Submitted: 2014-06-25 00:52 UTC Modified: 2014-06-25 01:14 UTC
From: j0101s at hotmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 5.4.29 OS: windows 7
Private report: No CVE-ID: None
 [2014-06-25 00:52 UTC] j0101s at hotmail dot com
Description:
------------
My environment is as below.

Windows 7
php 5.4.29
Apache/2.2.25


I set OPENSSL_CONF and also SSLEAY_CONF to a value where openssl.cnf is located.
I uncommented "extension=php_openssl.dll" and set "extension_dir = ext".
After reboot my computer, it works fine on command prompt. But it still does not work on a web. When I tried http://127.0.0.1/phpinfo.php , it still said "disabled (install ext/openssl) ". I think either web server or php can't find openssl.cnf on web environment. I tested this on my local computer.

I'm getting this error message:
Fatal error:  Call to undefined function openssl_pkey_new()

Somebody else is having the same problem.
http://grokbase.com/t/php/php-bugs/11awzjd6r5/php-bug-bug-60157-new-openssl-conf-environment-variable-ignored

I set up everything alright but I'm having the same problem.
Help me with this please.




Patches

Pull Requests

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-06-25 01:14 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2014-06-25 01:14 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

If you're able to get OpenSSL working anywhere else, including the command line, then the issue is that of the configuration for Apache.
Did you see the note on the openssl extension's installation page? Because the PATH used on the command line may not be the same one used by Apache.
http://www.php.net/manual/en/openssl.installation.php

Note that the other bug you linked to is/was a problem where the extension loads fine (yours is not loading at all, as shown by the "undefined function" error) but does not use the correct configuration file.
 
PHP Copyright © 2001-2026 The PHP Group
All rights reserved.
Last updated: Tue Oct 06 14:00:02 2026 UTC