php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67490 pecl.php.net - DB Error: connect failed
Submitted: 2014-06-21 11:10 UTC Modified: 2014-08-31 19:30 UTC
Votes:5
Avg. Score:4.6 ± 0.5
Reproduced:5 of 5 (100.0%)
Same Version:3 (60.0%)
Same OS:4 (80.0%)
From: chrkohlstedde at gmail dot com Assigned: tyrael (profile)
Status: Closed Package: Systems problem
PHP Version: 5.5.13 OS:
Private report: No CVE-ID: None
 [2014-06-21 11:10 UTC] chrkohlstedde at gmail dot com
Description:
------------
Hi there,

the pecl.php.net website is displaying a database connection error.

    DB Error: connect failed

Expected result:
----------------
Working website


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-06-21 16:55 UTC] sobak@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: sobak
 [2014-06-21 16:55 UTC] sobak@php.net
It works now, however, I don't know what was the reason of database problems.
 [2014-06-24 11:38 UTC] tyrael@php.net
we ran out of the maximum allowed mysql connections, when the daily backup job was running(because it locked highly contested tables).
For now I've doubled the max_connections, and we are planning to migrate the pecl site to a new vm (which also means using a more recent mysql version) and revisiting our backup policy would be required anyways.
 [2014-08-31 07:26 UTC] googleguy@php.net
-Status: Closed +Status: Re-Opened
 [2014-08-31 07:26 UTC] googleguy@php.net
It looks like this problem has cropped back up again. Site is currently showing "DB Error: connect failed", but 149.5.47.136 seems to be working fine.
 [2014-08-31 19:30 UTC] tyrael@php.net
-Status: Re-Opened +Status: Closed -Package: Website problem +Package: Systems problem -Assigned To: sobak +Assigned To: tyrael
 [2014-08-31 19:30 UTC] tyrael@php.net
it was the db backup script again locking the aggregated_package_stats indefinitely (when I killed it the SELECT /*!40001 SQL_NO_CACHE */ * FROM `aggregated_package_stats` query was running for more than 15 hours with the status of Writing to net).
unfortunatelly I wasn't around today, so next team please try pinging systems@ if this comes up, we have more than one person with access to that box.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Sep 29 00:01:24 2023 UTC