php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67426 Bug tracker no longer shows quick fixes
Submitted: 2014-06-12 16:05 UTC Modified: 2015-01-03 12:40 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: aharvey@php.net Assigned: sobak (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
 [2014-06-12 16:05 UTC] aharvey@php.net
Description:
------------
The bug tracker no longer shows any quick fixes: http://i.imgur.com/XgNC8eH.png

The select itself still appears; it's just empty.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-06-12 18:48 UTC] sobak@php.net
Probably the most unprofessional answer over here, but this commit SHOULD fix it. The reason why I'm unsure is that I don't know actual content of bugdb_pseudo_packages and schema in repo is poor. However, this change shouldn't break anything more so I will just leave this bug as open and wait for rsync.

https://github.com/php/web-bugs/commit/2b13da9454abee46614cc058df3fc03a033eabe8

Regards.
 [2014-06-12 19:11 UTC] sobak@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: sobak
 [2014-06-12 19:11 UTC] sobak@php.net
Seems it works.
 [2014-06-12 19:28 UTC] sobak@php.net
-Status: Closed +Status: Re-Opened
 [2014-06-12 19:28 UTC] sobak@php.net
Grrh, it works but only partially. It doesn't works for packages with PECL as a project.
 [2014-10-05 22:07 UTC] johannes@php.net
The reason is that the bug is in a "project" with no quick fix option applicable. 

See bugsweg www/bug.php aroudn line 170

$project = $bug['project'];
/* ...*/
if ($edit === 1) {
	list($RESOLVE_REASONS, $FIX_VARIATIONS) = get_resolve_reasons($project);
}

($bug comes from the database)

I think somebody should add some of the quick fixes to pecl, too. I don't have database access.
 [2014-12-31 05:54 UTC] sobak@php.net
What abot this? It seems that Johannes is right and in fact there is no problem with bugsweb - we just need more resolve reasons. However, I'm not sure if that's the way it worked before.
 [2015-01-03 12:40 UTC] jacob@php.net
-Status: Re-Opened +Status: Closed
 [2015-01-03 12:40 UTC] jacob@php.net
This now looks to be resolved as quick fixes are available again - https://s3.amazonaws.com/shares.jacobbednarz.com/resolve-reasons-working.png
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 19 23:01:29 2020 UTC