php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #67293 PHP online documentation navigation must be on the left
Submitted: 2014-05-16 18:15 UTC Modified: 2014-05-18 13:32 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: rrichey at ishway dot com Assigned: levim (profile)
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2014-05-16 18:15 UTC] rrichey at ishway dot com
Description:
------------
English online PHP documentation now has navigation on the right side of the screen.  It should be back on the left. This may seem a trite issue, but the collective PHP community has reflexive patterns of looking for navigation on the left side of the screen for all historical versions of this documentation.  

This is just silly, and makes me less efficient in my work.  Everything else in the world has left navigation as well.  This is NOT something that is a simple design choice.  It is about human beings and their technology usage patterns.  This needs to be moved left again. 

Expected result:
----------------
Navigation back on the left where it belongs.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-05-18 06:21 UTC] sobak@php.net
-Type: Documentation Problem +Type: Feature/Change Request -Package: Documentation problem +Package: Website problem -Assigned To: +Assigned To: levim
 [2014-05-18 13:32 UTC] levim@php.net
-Status: Assigned +Status: Wont fix
 [2014-05-18 13:32 UTC] levim@php.net
The problem with citing historical patterns is that if I leave it on the right long enough I could then cite historical reasons for having it on the right.

Furthermore, this is not a design choice and it never was; it fixes several issues on IE8, several mobile browsers, and when viewing PHP.net in split-screen on many screen sizes.

I'm not saying it's there to stay on the right forever; it definitely is staying there until someone can come up with solutions for the aforementioned problems while keeping it on the left side.
 [2014-07-24 15:46 UTC] php dot net at gerbig dot info
its not a good thing to throw away usability and design-standards & ergonomy aspects because of Bugs in ONE browser (IE8) and punish all users with that fix for that buggy M$-browser. So M4 should respect standards and do not do there own thing an try to push trough there mention of things which are not standard like.


I can see now effort for a menu on the right side also at mobil devices, if the coding is well there are no problems with left side menus on mobile device.
Problems on mobile device are regarding in 99,9% on bad coding of the websites!
Most problems with website i have on my mobil-device with sites which uses right-side menus/navigation....

And there will no historical reason for a important Content on the right side, there is no reason, and much enough surveys & studies have shown that all content on the right side will be ignored and has to be searched activly.

Im very interested in your historically cites for content regarding menus on the right side.

Prolbems are much more an heavier with menus on the right side than on left side.
The Problems are: usability (that the most important!), problems with mobiles devices (that should be fixed with right side menus? no way)

i tried oo.net at the moment on my mobile device.
its unusable with the acutall layout!
- there is no navigation any more possible.
- links lay under text
- incomplete text lines


 so please cite the historical arguments ...
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Jul 19 19:01:26 2019 UTC