php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67284 run-tests fails to submit results
Submitted: 2014-05-15 13:05 UTC Modified: 2014-05-23 02:45 UTC
From: garyamort at gmail dot com Assigned: aharvey (profile)
Status: Closed Package: Testing related
PHP Version: master-Git-2014-05-15 (Git) OS: Arch Linux 64bit
Private report: No CVE-ID: None
 [2014-05-15 13:05 UTC] garyamort at gmail dot com
Description:
------------
run-tests.php fails to properly submit reports.  

For debugging, I added a stream_get_contents after the fwrite calls and checked the result, it was a 200 OK from the server.  However, the bug report was not posted.

Moreover, If you check news.php.net/php.qa.reports/ you will see that there are NO automated submissions of reports from run-tests.php

Most of the reports are automated from PFTT, with a smattering of manually entered reports.

Kind of embarrassing that the Microsoft tool is working and not the the PHP tool.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-05-23 02:45 UTC] aharvey@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: aharvey
 [2014-05-23 02:45 UTC] aharvey@php.net
The introductory text on qa.php.net is out of date — run-tests.php submits the results directly to a Web service on qa.php.net, rather than to the QA reports mailing list. I've changed the text on the QA site to reflect that, although it may take a little while to appear on the live site.

You can view aggregated results from run-tests.php at http://qa.php.net/reports/run_tests.php.

Thanks for the report!
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Oct 19 09:01:26 2019 UTC