php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6721 ibase_execute() not working anymore (v 4.0.2 only)
Submitted: 2000-09-13 18:10 UTC Modified: 2000-10-27 22:35 UTC
From: futur at mad dot scientist dot com Assigned: jah (profile)
Status: Closed Package: InterBase related
PHP Version: 4.0.2 OS: Linux
Private report: No CVE-ID: None
 [2000-09-13 18:10 UTC] futur at mad dot scientist dot com
A script that is working properly on version 4.0.1pl2, using ibase_execute() seems to make php crash everytime it is executed on version 4.0.2 of php.

Seems like the function has been removed or execute some unsupported calls.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-09-13 19:53 UTC] futur at mad dot scientist dot com
a script using ibase_execute and working properly on version 4.0.1pl2 of php doesn't work  anymore on version 4.0.2

We have isolated the fault to the function ibase_execute().

PHP 4.02 is running as a static module for Apache 1.3.12
under Linux kernel 2.4.0test8.
 [2000-10-17 13:49 UTC] jah@php.net
This is hopefully fixed in CVS. Please replace ext/interbase/interbase.c with
http://cvs.php.net/viewcvs.cgi/~checkout~/php4/ext/interbase/interbase.c?rev=1.45
and recompile. And please also tell whether it worked or not...
 [2000-10-27 22:35 UTC] jah@php.net
No feedback, but as this is the same problem as in #7117 that was confirmed to
be fixed by reporter, closing.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 07:03:36 2021 UTC