php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #67136 Please make mta optional
Submitted: 2014-04-27 13:47 UTC Modified: 2014-04-29 10:37 UTC
From: cj dot wijtmans at gmail dot com Assigned:
Status: Not a bug Package: *Mail Related
PHP Version: 5.5.11 OS: Gentoo
Private report: No CVE-ID: None
 [2014-04-27 13:47 UTC] cj dot wijtmans at gmail dot com
Description:
------------
is mta a requirement or optional for building php?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-04-27 21:43 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2014-04-27 21:43 UTC] rasmus@php.net
This is a bug reporting system, not a support channel. But no, PHP has no dependency in any sort of MTA.
 [2014-04-28 14:13 UTC] cj dot wijtmans at gmail dot com
there is no sendmail config flag as far as i know. valid bug.
 [2014-04-28 22:12 UTC] rasmus@php.net
Just set the sendmail_path ini to whatever you want. Set it to the empty string "" and mail() will obviously not work or set it to whatever mail delivery mechanism you want. Either way, there is no hard dependency on an MTA so the bug as stated is invalid.
 [2014-04-29 08:30 UTC] cj dot wijtmans at gmail dot com
Gentoo has something called useflags that allow control over how the package is build. Auto configured sendmail in this case is a nightmare to maintain. Right now the devs simply wont remove the MTA hard dependency or replace it with a MTA use flag for that reason since turning on or off an MTA useflag right now wont gaurentee control over how PHP is compiled with or without sendmail support.
I hope you understand the issue at hand now.
 [2014-04-29 10:37 UTC] rasmus@php.net
Well, since there is no dependency in PHP on an MTA, the fact that Gentoo has made sendmail a dependency is their problem, not ours. There is simply nothing we can fix on our end since there is no build-time dependency we can remove here. Absolutely nothing during the PHP build depends on sendmail or any other MTA.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 20:01:29 2024 UTC