php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66956 Incorrect link
Submitted: 2014-03-26 05:18 UTC Modified: 2014-03-26 14:56 UTC
From: hannes dot magnusson at gmail dot com Assigned: sobak (profile)
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS: *
Private report: No CVE-ID: None
 [2014-03-26 05:18 UTC] hannes dot magnusson at gmail dot com
Description:
------------
http://doc.php.net/
Click Japanese -> http://doc.php.net/revcheck.php?lang=ja 

"Please choose a specified tool from the right side."

Only lang=en seems to work.


The translation mailinglists should also be mentioned somewhere, so people interested in helping out can contact someone (doc-<lang>@lists.php.net).
phpdoc@lists.php.net should also be mentioned :]


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-03-26 05:18 UTC] bjori@php.net
-Assigned To: +Assigned To: sobak
 [2014-03-26 13:32 UTC] sobak@php.net
-Status: Assigned +Status: Not a bug
 [2014-03-26 13:32 UTC] sobak@php.net
Revcheck is working. After you choose a language menu on the right sidebar changes. It shows list of available tools for specified language. However, the fact that you reported is as a bug means that this comunicate isn't clear enough. Any suggestions to improve this?

"The translation mailinglists should also be mentioned somewhere, so people interested in helping out can contact someone (doc-<lang>@lists.php.net).
phpdoc@lists.php.net should also be mentioned :]"
I think that proper place to mention this is just a page you are talking about. So page displayed when user selected language and haven't selected tool yet. Probably we can also add another tab in the top menu.
 [2014-03-26 14:24 UTC] bjori@php.net
When I click English from that language list, I see a pretty revcheck graph.
When I pick other languages I get what I thought was an error ("Please choose a specified tool from the right side.").

If the language links don't do the same thing.. I would rename English to "revcheck", then add some border below it, and then list the translations
 [2014-03-26 14:50 UTC] sobak@php.net
Maybe just replace headline "Languages" with link to "English" graph?

Another idea: maybe just move "Graph" (http://doc.php.net/revcheck.php?p=graph&lang={lang}) on the default site? So general graph for English and language-specific graph for other langs.
 [2014-03-26 14:56 UTC] bjori@php.net
I like your first idea better - or just name it "Translation status" or anything that actual describes what I am looking it :)

But the text "Graph" doesn't tell me anything, it need to be more descriptive so I will want to click it :)
 [2014-03-29 11:55 UTC] sobak@php.net
I improved communicates - https://github.com/php/web-doc/commit/308eefcfa33ae20ab5a35fa119eb9f73486f1e3f - it would be nice if you could review this commit. I probably made some language mistakes and your English is much better than mine.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 04:05:53 2022 UTC