php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66909 configure fails utf8_to_mutf7 test
Submitted: 2014-03-14 22:29 UTC Modified: 2015-12-09 11:06 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: mdwong at honolulu dot gov Assigned: ab
Status: Closed Package: *Configuration Issues
PHP Version: 5.5.10 OS:
Private report: No CVE-ID:
 [2014-03-14 22:29 UTC] mdwong at honolulu dot gov
Description:
------------
testing for IMAP, configure calls utf8_to_mutf7() with no argument, causing a core dump in Linux on S/390 IFL.  utf8_to_mutf7() requires one argument. Editing configure to this fixes the problem:


    char utf8_to_mutf7();
    char testarg[20];
    strcpy (testarg, "");
    int main() {
      utf8_to_mutf7(testarg);
      return 0;
    }



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-11-09 16:33 UTC] michael at orlitzky dot com
We've seen this problem on Gentoo as well. I believe it is the root cause of this bug report,

  https://bugs.gentoo.org/show_bug.cgi?id=376735

and that the submitter's diagnosis is correct. In utf8aux.h we can clearly see,

  unsigned char *utf8_to_mutf7 (unsigned char *src);
 [2015-11-09 17:18 UTC] michael at orlitzky dot com
https://github.com/php/php-src/pull/1627
 [2015-12-09 11:06 UTC] ab@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: ab
 [2015-12-09 11:06 UTC] ab@php.net
Merged in 24f21a30121b24a74f9cc0fd4a4cb0541ad8f520.

Thanks.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC