php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66840 use of undeclared identifiers 'DEFAULT_RENEG_LIMIT', 'DEFAULT_RENEG_WINDOW'
Submitted: 2014-03-07 02:29 UTC Modified: 2014-04-13 20:59 UTC
From: php-bugs-2014 at ryandesign dot com Assigned: rdlowrey
Status: Closed Package: OpenSSL related
PHP Version: 5.6.0alpha3 OS: OS X 10.9.2
Private report: No CVE-ID:
 [2014-03-07 02:29 UTC] php-bugs-2014 at ryandesign dot com
Description:
------------
Hello, I'm the maintainer of php in MacPorts. I'm trying to update our php56 ports to version 5.6.0alpha3. The openssl extension is failing to build, as follows:


/opt/local/var/macports/build/_Users_rschmidt_macports_dports_lang_php/php56-openssl/work/php-5.6.0alpha3/ext/openssl/xp_ssl.c:390:15: error: use of undeclared identifier 'DEFAULT_RENEG_LIMIT'
        long limit = DEFAULT_RENEG_LIMIT;
                     ^
/opt/local/var/macports/build/_Users_rschmidt_macports_dports_lang_php/php56-openssl/work/php-5.6.0alpha3/ext/openssl/xp_ssl.c:391:16: error: use of undeclared identifier 'DEFAULT_RENEG_WINDOW'
        long window = DEFAULT_RENEG_WINDOW;
                      ^
2 errors generated.
make: *** [xp_ssl.lo] Error 1


Note that we're building the extension separately from php, using phpize and a separate configure and make. 5.6.0alpha2 built fine.

DEFAULT_RENEG_LIMIT and DEFAULT_RENEG_WINDOW are defined in php_openssl.h if HAVE_OPENSSL_EXT is defined. HAVE_OPENSSL_EXT is defined to 1 in config.h. xp_ssl.c does #include php_openssl.h. So perhaps the problem is that config.h isn't being #included. I copied the lines to do that from openssl.c to xp_ssl.c, and now it builds successfully. The patch is attached.


Patches

ext-openssl-xp_ssl.c.diff (last revision 2014-03-07 02:29 UTC) by php-bugs-2014 at ryandesign dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-04-13 20:28 UTC] tyrael@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: rdlowrey
 [2014-04-13 20:28 UTC] tyrael@php.net
Daniel, could you look into this please?
 [2014-04-13 20:40 UTC] rdlowrey@php.net
Looking into it ...
 [2014-04-13 20:59 UTC] rdlowrey@php.net
Sorry, I didn't see this report earlier. This should be fixed in 27849c998a from a few weeks ago:

https://github.com/php/php-src/commit/27849c998a77a093449dec4b051dfc266d5123ec

I've spoken with at least one person who has since built the extension on MacOS without issue. The beta1 release is building fine for me in windows and the few linux distros I've tested, though I do not have access to Mac to test specifically there.

I'm closing the report for now (due to the reasons above). Please update this bug report if the issue persists for you with the beta1 release. Thanks again for the report and my apologies for not getting to it sooner!
 [2014-04-13 20:59 UTC] rdlowrey@php.net
-Status: Assigned +Status: Closed
 [2014-04-13 21:22 UTC] rdlowrey@php.net
Woops, I didn't read the report closely enough :)

This is *actually* fixed with 0e023e9784:

https://github.com/php/php-src/commit/0e023e978445a7d2f723cabfd4a59d65886be72a
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC