php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #66717 Meaning of flags is not included in documentation
Submitted: 2014-02-14 23:40 UTC Modified: 2015-05-18 15:59 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: papaulsh at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: Zip Related
PHP Version: 5.5.9 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: papaulsh at gmail dot com
New email:
PHP Version: OS:

 

 [2014-02-14 23:40 UTC] papaulsh at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/ziparchive.open
---
The noted method provides for the passing of a "FLAG" value which can take on the value of "CREATE" "OVERWRITE" "EXCL" or "CHECKCONS" but there is no description of what these various settings mean???


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-04-16 01:23 UTC] cmb@php.net
-Package: zip +Package: Zip Related -Assigned To: +Assigned To: cmb
 [2015-04-16 12:19 UTC] cmb@php.net
-Status: Assigned +Status: Verified -Assigned To: cmb +Assigned To:
 [2015-04-16 12:19 UTC] cmb@php.net
The meaning of the constants is documented on the package's
constant man page[1], but I think the descriptions should also be
available or linked on the method's man page.

[1] <http://php.net/manual/en/zip.constants.php>
 [2015-05-18 15:59 UTC] cmb@php.net
-Status: Verified +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2015-05-18 15:59 UTC] cmb@php.net
Actually, this is a duplicate of bug #60971.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 13:01:23 2020 UTC