php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66679 Alignment Bug in PCRE 8.34 upstream
Submitted: 2014-02-09 17:40 UTC Modified: 2014-12-30 15:56 UTC
From: rainer dot jung at kippdata dot de Assigned: ab
Status: Closed Package: PCRE related
PHP Version: 5.6Git-2014-02-09 (Git) OS: Solaris
Private report: No CVE-ID:
 [2014-02-09 17:40 UTC] rainer dot jung at kippdata dot de
Description:
------------
alignment.patchaPCRE 8.34 has an alignment bug on Solaris that leads to crashes (bus error):

http://bugs.exim.org/show_bug.cgi?id=1427

The bug was fixed as part of a huge commit:

http://vcs.pcre.org/viewvc?view=revision&revision=1415

I extracted a smaller patch I'll attach.


Patches

66679_clean.patch (last revision 2014-06-04 09:36 UTC) by ab@php.net)
PCRE-Alignment-8_34 (last revision 2014-02-09 17:41 UTC) by rainer dot jung at kippdata dot de)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-06-03 07:26 UTC] tyrael@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: ab
 [2014-06-03 07:26 UTC] tyrael@php.net
Anatol, could you look into this?
 [2014-06-03 20:13 UTC] ab@php.net
Thanks for reporting, Rainer. You're right, the only what matters for us is

http://vcs.pcre.org/viewvc/code/trunk/pcre_compile.c?r1=1415&r2=1414&pathrev=1415

as we still have JIT not enabled in PCRE. Gonna test this on windows/linux so you could check the solaris part after it's applied.

Cheers.
 [2014-06-04 07:55 UTC] rainer dot jung at kippdata dot de
I think the bug is fixed in the upstream PCRE 8.35 release available since 8 weeks. So instead of applying a custom patch, another update might be better?
 [2014-06-04 09:36 UTC] ab@php.net
The following patch has been added/updated:

Patch Name: 66679_clean.patch
Revision:   1401874600
URL:        https://bugs.php.net/patch-display.php?bug=66679&patch=66679_clean.patch&revision=1401874600
 [2014-06-04 09:39 UTC] ab@php.net
-Status: Assigned +Status: Feedback
 [2014-06-04 09:39 UTC] ab@php.net
Maybe, but not that close to the 5.6 final. I'd take upgrade as the last measure at this moment.

Rainer, I've cleaned up so it contains only the part relevant to the alignment. Still have no solaris machine, so please test this 66679_clean.patch . For me it's fine on linux and windows.

Thanks.
 [2014-12-30 10:42 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2014-12-30 14:59 UTC] rainer dot jung at kippdata dot de
Sorry for the long delay: I can confirm, that your patch is fine.
The patch needs to get applied to the 5.5 and 5.6 branches, it is neither yet part of the latest releases nor of head of 5.5/5.6.
Master is already on PCRE 8.35.
Thank you!

Rainer
 [2014-12-30 15:53 UTC] ab@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=d5123415f680b9c70ec44309f0bce3f0a512ee52
Log: Fixed bug #66679 Alignment Bug in PCRE 8.34 upstream
 [2014-12-30 15:53 UTC] ab@php.net
-Status: No Feedback +Status: Closed
 [2014-12-30 15:56 UTC] ab@php.net
Rainer, thanks for checking. Yeah, master has 8.35 now, lets see what we have there when it's branched (8.36 is there already). 

Thanks
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Jul 23 02:01:35 2017 UTC