php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66645 Cannot build pecl rar extension
Submitted: 2014-02-05 06:10 UTC Modified: 2014-02-07 07:52 UTC
From: allzero at tut dot by Assigned:
Status: Not a bug Package: rar (PECL)
PHP Version: 5.4.24 OS: Windows XP
Private report: No CVE-ID: None
 [2014-02-05 06:10 UTC] allzero at tut dot by
Description:
------------
rar extension 3.0.2
Visual C++ 2008
May be required some external library?


Journal:

libiconv_a.lib(iconv1.obj) : найден .netmodule MSIL или модуль, откомпилированны
й с параметром /GL; перезапускается компоновка с параметром /LTCG; добавьте /LTC
G в командную строку компоновки для повышения производительности компоновщика
   Создается библиотека Release_TS\php5ts.lib и объект Release_TS\php5ts.exp
extract.obj : error LNK2001: неразрешенный внешний символ ""public: void __thisc
all SecPassword::Set(wchar_t const *)" (?Set@SecPassword@@QAEXPB_W@Z)"
extractchunk.obj : error LNK2001: неразрешенный внешний символ ""public: void __
thiscall SecPassword::Set(wchar_t const *)" (?Set@SecPassword@@QAEXPB_W@Z)"
arcread.obj : error LNK2001: неразрешенный внешний символ ""public: void __thisc
all SecPassword::Set(wchar_t const *)" (?Set@SecPassword@@QAEXPB_W@Z)"
cmddata.obj : error LNK2001: неразрешенный внешний символ ""public: void __thisc
all SecPassword::Set(wchar_t const *)" (?Set@SecPassword@@QAEXPB_W@Z)"
crypt.obj : error LNK2001: неразрешенный внешний символ ""public: void __thiscal
l SecPassword::Set(wchar_t const *)" (?Set@SecPassword@@QAEXPB_W@Z)"
dll.obj : error LNK2001: неразрешенный внешний символ ""public: void __thiscall
SecPassword::Set(wchar_t const *)" (?Set@SecPassword@@QAEXPB_W@Z)"
extract.obj : error LNK2001: неразрешенный внешний символ ""void __cdecl cleanda
ta(void *,unsigned int)" (?cleandata@@YAXPAXI@Z)"
extractchunk.obj : error LNK2001: неразрешенный внешний символ ""void __cdecl cl
eandata(void *,unsigned int)" (?cleandata@@YAXPAXI@Z)"
sha1.obj : error LNK2001: неразрешенный внешний символ ""void __cdecl cleandata(
void *,unsigned int)" (?cleandata@@YAXPAXI@Z)"
arcread.obj : error LNK2001: неразрешенный внешний символ ""void __cdecl cleanda
ta(void *,unsigned int)" (?cleandata@@YAXPAXI@Z)"
cmddata.obj : error LNK2001: неразрешенный внешний символ ""void __cdecl cleanda
ta(void *,unsigned int)" (?cleandata@@YAXPAXI@Z)"
crypt.obj : error LNK2001: неразрешенный внешний символ ""void __cdecl cleandata
(void *,unsigned int)" (?cleandata@@YAXPAXI@Z)"
dll.obj : error LNK2001: неразрешенный внешний символ ""void __cdecl cleandata(v
oid *,unsigned int)" (?cleandata@@YAXPAXI@Z)"
crypt.obj : error LNK2001: неразрешенный внешний символ ""public: __thiscall Sec
Password::~SecPassword(void)" (??1SecPassword@@QAE@XZ)"
extract.obj : error LNK2001: неразрешенный внешний символ ""public: __thiscall S
ecPassword::~SecPassword(void)" (??1SecPassword@@QAE@XZ)"
options.obj : error LNK2001: неразрешенный внешний символ ""public: __thiscall S
ecPassword::~SecPassword(void)" (??1SecPassword@@QAE@XZ)"
crypt.obj : error LNK2001: неразрешенный внешний символ ""public: __thiscall Sec
Password::SecPassword(void)" (??0SecPassword@@QAE@XZ)"
extract.obj : error LNK2001: неразрешенный внешний символ ""public: __thiscall S
ecPassword::SecPassword(void)" (??0SecPassword@@QAE@XZ)"
options.obj : error LNK2001: неразрешенный внешний символ ""public: __thiscall S
ecPassword::SecPassword(void)" (??0SecPassword@@QAE@XZ)"
crypt.obj : error LNK2001: неразрешенный внешний символ ""public: bool __thiscal
l SecPassword::operator==(class SecPassword &)" (??8SecPassword@@QAE_NAAV0@@Z)"
crypt.obj : error LNK2001: неразрешенный внешний символ ""public: void __thiscal
l SecPassword::Get(wchar_t *,unsigned int)" (?Get@SecPassword@@QAEXPA_WI@Z)"
extract.obj : error LNK2001: неразрешенный внешний символ ""public: void __thisc
all SecPassword::Get(wchar_t *,unsigned int)" (?Get@SecPassword@@QAEXPA_WI@Z)"
Release_TS\php5ts.dll : fatal error LNK1120: 6 неразрешенных внешних элементов
NMAKE : fatal error U1077: "C:\Program Files\Microsoft Visual Studio 9.0\VC\Bin\
cl.exe": возвращенный код "0x2"
Stop.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-02-05 08:28 UTC] tony2001@php.net
-Status: Open +Status: Feedback
 [2014-02-05 08:28 UTC] tony2001@php.net
Please make sure you're using the correct .dep file.
You can download all the files used for the official PHP builds here: http://windows.php.net/downloads/php-sdk/
 [2014-02-05 09:00 UTC] allzero at tut dot by
-Status: Feedback +Status: Open
 [2014-02-05 09:00 UTC] allzero at tut dot by
Form PHP 5.4.24 sdk-binary is php-sdk-binary-tools-20110915.zip?

In this archive no have links for php 5.4 and on http://windows.php.net/downloads/php-sdk/ i not found another sdk archive.
 [2014-02-05 09:33 UTC] tony2001@php.net
-Status: Open +Status: Feedback
 [2014-02-05 09:33 UTC] tony2001@php.net
I don't get your question, sorry.

There's some 5.4-related file - http://windows.php.net/downloads/php-sdk/deps-5.4-vc9-x86.7z, but I have no idea whatsoever about building DLLs on Windows, so I don't know if it's the one you're looking for.

Also, did you try this DLL http://pecl.php.net/package/rar/3.0.1/windows ?

In case if you want to talk directly to MS developers, visit #php.pecl IRC channel on EFNet.
 [2014-02-07 07:52 UTC] tony2001@php.net
-Status: Feedback +Status: Not a bug
 [2014-02-07 07:52 UTC] tony2001@php.net
Obviously, some misconfiguration on user side.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Aug 23 16:01:26 2019 UTC