php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66605 socket_write suspends execution
Submitted: 2014-01-29 12:27 UTC Modified: 2014-02-05 09:39 UTC
From: jitesh dot prajapati at infostretch dot com Assigned:
Status: Duplicate Package: Sockets related
PHP Version: Irrelevant OS: Cent OS 6/Ubuntu
Private report: No CVE-ID: None
 [2014-01-29 12:27 UTC] jitesh dot prajapati at infostretch dot com
Description:
------------
Hello Executive,

I have implemented web socket server in php.

Server works fine for some amount of time (I can say 15-20 mins), then after at some point execution of script got suspended and it goes to some wait/deadlock condition.

I have put debugging points and found that it goes to suspend/wait/deadlock condition on socket_write function.

I tried many ways but do not luck.

Can you recommend any solution for same?



Test script:
---------------
http://202.131.96.147/test/wevsocketclass.php (Here is our server code)

Expected result:
----------------
Server must be working continuously and do not stuck at any point.

Actual result:
--------------
Server goes to suspend/stuck/wait/deadlock situation intermittently.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-01-29 18:20 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2014-01-29 18:20 UTC] requinix@php.net
Duplicate of bug #66572
 [2014-02-05 09:39 UTC] jitesh dot prajapati at infostretch dot com
-Operating System: Cent OS 6 +Operating System: Cent OS 6/Ubuntu
 [2014-02-05 09:39 UTC] jitesh dot prajapati at infostretch dot com
Hi Executive,

I am frequently writing into sockets (I can say 3times in a sec.).

It works fine, but after some time it wait to write (socket_write) and it does not able to write because of some reason. 

Does it buffer full issue or something else?

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Oct 19 15:01:23 2020 UTC