php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #66598 Consider picking up efforts for Mono integration.
Submitted: 2014-01-28 22:48 UTC Modified: 2017-04-01 20:55 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: atrauzzi at gmail dot com Assigned:
Status: Wont fix Package: mono (PECL)
PHP Version: Irrelevant OS: Linux/Ubuntu
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2014-01-28 22:48 UTC] atrauzzi at gmail dot com
Description:
------------
I think there are ongoing circumstances where someone might wish to author or leverage existing business logic in an application that has been compiled to MSIL from PHP.

Unfortunately, the current approach requires them to be running PHP on Windows, which likely given that requirement would be the last straw in having them switch entirely over to a .NET solution.

It would be great if development of the PHP-Mono bridge was rekindled so that PHP developers can offer first-class support for business libraries authored in C# from platforms other than Windows.

I had a look at the existing source code for the Mono bridge, but unfortunately it's well over my head.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 20:55 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 20:55 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2003, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Sep 22 07:03:28 2021 UTC