php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #66548 Adopt semantic versioning
Submitted: 2014-01-22 16:59 UTC Modified: 2014-12-29 06:54 UTC
Votes:3
Avg. Score:3.0 ± 1.6
Reproduced:2 of 3 (66.7%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: php dot net at phor dot net Assigned:
Status: Wont fix Package: Documentation problem
PHP Version: 5.5.8 OS: Any
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2014-01-22 16:59 UTC] php dot net at phor dot net
Description:
------------
PHP 5.4 introduced backwards incompatible changes in a "point" release. Backlash was significant and it is hard to find a cheap web host out there that will ever upgrade... and this is almost 2 years since the release.

Please never do this again.

Please adopt an official pledge to support semantic versioning.



Expected result:
----------------
Major number increases when backwards-incompatible changes are introduced.

Actual result:
--------------
Everyone is afraid to upgrade. We have the "Android" problem of version management. PHP will be begged to support 5.3 long past its end-of-support date, a la Windows XP. Upgrading PHP 5.3 to the latest version will be as painful for enterprise as rewriting code in Python.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-12-29 06:54 UTC] sobak@php.net
-Status: Open +Status: Wont fix
 [2014-12-29 06:54 UTC] sobak@php.net
Hello,

new PHP releases adhere to the https://wiki.php.net/rfc/releaseprocess You should also note that BC-breaking changes applied to deprecated feautres.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 00:01:33 2024 UTC