php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66452 error on pages
Submitted: 2014-01-09 19:43 UTC Modified: 2015-02-18 21:14 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: slchouinard at arkbluecross dot com Assigned: jacob (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS: Windows Vista, ie 8
Private report: No CVE-ID: None
 [2014-01-09 19:43 UTC] slchouinard at arkbluecross dot com
Description:
------------
Webpage error when trying to view the various code documentation pages in IE8.  

Expected result:
----------------
no errors on page.

Actual result:
--------------
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729; InfoPath.3; .NET4.0C)
Timestamp: Thu, 9 Jan 2014 19:40:27 UTC


Message: Not enough storage is available to complete this operation.

Line: 248
Char: 25
Code: 0
URI: http://us3.php.net/cached.php?t=1388140826&f=/js/search.js



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-01-09 21:46 UTC] bjori@php.net
-Type: Documentation Problem +Type: Bug -Package: *General Issues +Package: Website problem
 [2014-01-30 08:45 UTC] vovan-ve at yandex dot ru
The error is caused by exceeding per-site limit for local storage. DOMException: QUOTA_EXCEEDED_ERR

The search input in the header uses jQuery.fn.search plugin. Site tries to save JSON (like this: https://gist.github.com/anonymous/8703100) in localStorage with 'search-${LANGUAGE_NAME}' key. This JSON currently has size about 1М. I checked just now EN and RU languages - both JSON are same. So, I have 2 same huge JSONs ('search-ru' and 'search-en') in local storage of php.net

Faling to save hige JSON cause browser to perform new same AJAX request for that JSON on every next page loads. It goes without HTTP caching. So, we has +1MB on each page load.

The problem goes from logic. I doesn't need that search field on every page load even. Why it loads and stores tons of useless data?
 [2014-01-30 14:06 UTC] slchouinard at arkbluecross dot com
changed browser to ie9 and no more problems.  it's a compatability issue between the current php.net pages and ie8.
 [2014-01-31 04:17 UTC] vovan-ve at yandex dot ru
In fact, it does not matter, what browser we use. All adequate browser has limit for local storage. Sometimes this limit is configurable, sometimes not. Anyway, user doesn't want to store tons of data, which actually never will be used.
 [2015-02-18 21:14 UTC] jacob@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: jacob
 [2015-02-18 21:14 UTC] jacob@php.net
Hi,
As this was listed as an issue within IE8 can you please retest and reopen if
this is still a problem?

Thanks.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Sep 26 11:01:26 2018 UTC