php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66449 Syntax error generate Internal Server Error
Submitted: 2014-01-09 11:45 UTC Modified: 2014-01-09 12:19 UTC
From: smougel at idiway dot fr Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.5.7 OS: Gentoo
Private report: No CVE-ID: None
 [2014-01-09 11:45 UTC] smougel at idiway dot fr
Description:
------------
Following the upgrade to PHP 5.5.7, a script error as $test = 'foo' ||'';, will generate a "Internal Server Error" if output_bufferring is enabled.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-01-09 12:19 UTC] derick@php.net
-Status: Open +Status: Not a bug
 [2014-01-09 12:19 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

This is deliberate. If there has been no output, PHP will send a HTTP 500 status to signal that something went wrong. PHP can not do this if out has already been sent, so you will only see this HTTP 500 error in case there was no output yet — and output buffering facilitates that.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Jan 31 17:05:53 2023 UTC