php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66393 "Incorrect CAPTCHA" trying to file a bug report
Submitted: 2014-01-02 20:33 UTC Modified: 2014-02-05 21:22 UTC
Votes:2
Avg. Score:2.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: chealer at gmail dot com Assigned: danielc (profile)
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2014-01-02 20:33 UTC] chealer at gmail dot com
Description:
------------
As reported in #53255, when filing a bug report, bugs.php.net [almost] always asks:


Are you sure that you searched before you submitted your bug report? We found the following bugs that seem to be similar to yours; please check them before sumitting the report as they might contain the solution you are looking for.

If you're sure that your report is a genuine bug that has not been reported before, you can scroll down and click the submit button to really enter the details into our database.


Clicking the submit button fails with:


ERROR:

    * Incorrect Captcha


even if the captcha was correct (this happened to me at least 8 times). Then one can solve another captcha, re-submit and the report will be actually filed.


1 person out of 3 failed to reproduce this. However, I can't confirm that person was actually requested for a confirmation before submission. This seems to reproduce every time here.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-01-02 20:38 UTC] chealer at gmail dot com
when I opened this very ticket, the confirmation step pointed me to #33449. I then tested a different workaround, which worked. In the confirmation step, the CAPTCHA is blank, as if the answer had been lost. I re-entered the answer to the CAPTCHA and managed to file this ticket without getting any error.

This may simply be a specific symptom of bug #33449.
 [2014-01-03 03:41 UTC] danielc@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: danielc
 [2014-01-03 03:41 UTC] danielc@php.net
Yes.  The second submit requires the user to answer a new CAPTCHA.  Annoying, but not that big a deal.  Thanks for your report.
 [2014-01-03 23:24 UTC] anon at anon dot anon
Note that the CAPTCHA here requires cookies. If you browse with cookies disabled all it says is "Incorrect Captcha". I realize that those of us who have cookies disabled are rare, but that warning could use some improvement. The first time I tried it I think it took me a while to guess I needed to add a cookies exception for php.net.
 [2014-01-05 01:11 UTC] chealer at gmail dot com
My pleasure danielc, but could you explain how this wouldn't constitute a bug?


Indeed, the message appears to be thrown whenever the tracker fails to verify the CAPTCHA, either due to missing cookies, session information, or other reasons.
 [2014-01-05 01:52 UTC] danielc@php.net
-Block user comment: No +Block user comment: Yes
 [2014-01-05 01:52 UTC] danielc@php.net
I just made three commits to improve the user experience.

One set tells users that cookies are required if the SESSION information is unavailable.

The other part emphasizes that the CAPTCHA needs to be answered again.
 [2014-02-05 21:22 UTC] danielc@php.net
The changes made in early January have finally been deployed to the bugs web server.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 01:01:25 2019 UTC