php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #66351 inconsistent Phar versions
Submitted: 2013-12-26 05:08 UTC Modified: 2013-12-26 07:02 UTC
From: terrafrost at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2013-12-26 05:08 UTC] terrafrost at gmail dot com
Description:
------------
According to <http://us3.php.net/manual/en/phar.requirements.php> "Phar requires PHP 5.2.0 or newer". But <http://us3.php.net/manual/en/class.phar.php> says "PHP >= 5.3.0".

In the PHP 5.x changelogs I see "Added phar extension for handling PHP Archives. (Greg, Marcus, Steph)" under 5.3.0 and no mention of it before that so it seems like <http://us3.php.net/manual/en/phar.requirements.php> should be updated?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-26 07:02 UTC] bjori@php.net
-Status: Open +Status: Not a bug
 [2013-12-26 07:02 UTC] bjori@php.net
The version info says '(PHP >= 5.3.0, PECL phar >= 1.0.0)'

Meaning, it is available as a PECL extension, but then became a built-in extension in PHP 5.3.0

As the requirements page says, the (PECL) extension requires 5.2.0.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Apr 15 12:01:24 2021 UTC