php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66296 Crash upon completion of running php from CLI
Submitted: 2013-12-15 06:21 UTC Modified: 2015-02-03 23:20 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: skizzerz at gmail dot com Assigned: ericsten (profile)
Status: Wont fix Package: WinCache (PECL)
PHP Version: 5.4.23 OS: Windows 7 (64-bit)
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2013-12-15 06:21 UTC] skizzerz at gmail dot com
Description:
------------
Upon completing any script from CLI (both php.exe and php-cgi.exe), the console hangs momentarily and Windows reports that the process has crashed. WinCache functions properly when run from FastCGI in IIS. The report mentions php_wincache.dll as the culprit and offers the following traces (I tried with both the 1.3.5.0 release as well as the latest SVN trunk version):

1.3.5.0:
Problem Event Name:	BEX
Application Name:	php.exe
Application Version:	5.4.23.0
Application Timestamp:	52acfe82
Fault Module Name:	php_wincache.dll_unloaded
Fault Module Version:	0.0.0.0
Fault Module Timestamp:	52acfe7d
Exception Offset:	03931300
Exception Code:	c0000005
Exception Data:	00000008
OS Version:	6.1.7601.2.1.0.256.1
Locale ID:	1033
Additional Information 1:	0a9e
Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
Additional Information 3:	0a9e
Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

SVN trunk (r332173):
Problem Event Name:	BEX
Application Name:	php.exe
Application Version:	5.4.23.0
Application Timestamp:	52acfe82
Fault Module Name:	php_wincache.dll_unloaded
Fault Module Version:	0.0.0.0
Fault Module Timestamp:	52ad46f1
Exception Offset:	04411300
Exception Code:	c0000005
Exception Data:	00000008
OS Version:	6.1.7601.2.1.0.256.1
Locale ID:	1033
Additional Information 1:	0a9e
Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
Additional Information 3:	0a9e
Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

I compile PHP as well as the WinCache extension from source using Visual Studio 2008 (vc9). I can provide any additional information desired, such as other extensions installed and the configure command used.

Notable information:
Zend Extensions:
* ionCube PHP Loader v4.4.4
* XDebug v2.2.2
Tread Safety: enabled

Test script:
---------------
Anything. I've been testing with the builtin phpinfo() command by running php -i.

Expected result:
----------------
Displays phpinfo() and exits normally

Actual result:
--------------
Displays phpinfo() and crashes with the above message

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-02-20 16:27 UTC] ericsten@php.net
-Assigned To: +Assigned To: ericsten
 [2014-02-20 16:27 UTC] ericsten@php.net
We don't really test the thread safe variant of Wincache, since the primary target is Fast-CGI.
I'll look at this while I'm working on the PHP 5.6 release.
Thx!
    --E.
 [2015-02-03 23:20 UTC] ericsten@php.net
-Status: Assigned +Status: Wont fix
 [2015-02-03 23:20 UTC] ericsten@php.net
We don't really support the thread safe version of WinCache.
In the current version of WinCache (1.3.7.1) we have fixed a number of crashes arising from error conditions, especially during startup.  Hopefully your issue has already been fixed.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 14:01:25 2019 UTC