php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66239 Fpm won't error_log to syslog, php works fine
Submitted: 2013-12-05 12:57 UTC Modified: 2014-07-11 11:04 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: sjon at hortensius dot net Assigned: remi (profile)
Status: Closed Package: FPM related
PHP Version: 5.5.6 OS: archlinux
Private report: No CVE-ID: None
 [2013-12-05 12:57 UTC] sjon at hortensius dot net
Description:
------------
I put this in php-fpm.conf:

php_admin_value[error_log] = syslog

It results in 

> php-fpm -tt 2>&1|grep error_l
NOTICE: 	php_admin_value[error_log] = /usr/syslog

Obviously, this doesn't work. If I put this value in my php.ini however, it works fine!


Patches

fpm-syslog-bug.patch (last revision 2013-12-06 11:56 UTC by krakjoe@php.net)
fpm-syslog-bug-alternate.patch (last revision 2013-12-06 11:55 UTC by krakjoe@php.net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-06 08:04 UTC] krakjoe@php.net
The following patch has been added/updated:

Patch Name: fpm-syslog-bug.patch
Revision:   1386317045
URL:        https://bugs.php.net/patch-display.php?bug=66239&patch=fpm-syslog-bug.patch&revision=1386317045
 [2013-12-06 08:04 UTC] krakjoe@php.net
fpm fails to check for "syslog" before expanding the path, patch attached
 [2013-12-06 09:52 UTC] tony2001@php.net
But why do you change fpm_evaluate_full_path()? It's used everywhere and php_value/php_admin_value is just one use case.
I believe you should be changing the checks in this 'if' instead:
        /* env[], php_value[], php_admin_values[] */
        if (!wp->config->chroot) {
 [2013-12-06 11:47 UTC] krakjoe@php.net
Why depend on wp->config->chroot ?

Can you think of a case where it is reasonable for "syslog" to be expanded ?
 [2013-12-06 11:55 UTC] krakjoe@php.net
The following patch has been added/updated:

Patch Name: fpm-syslog-bug-alternate.patch
Revision:   1386330937
URL:        https://bugs.php.net/patch-display.php?bug=66239&patch=fpm-syslog-bug-alternate.patch&revision=1386330937
 [2013-12-06 11:56 UTC] krakjoe@php.net
The following patch has been added/updated:

Patch Name: fpm-syslog-bug.patch
Revision:   1386331016
URL:        https://bugs.php.net/patch-display.php?bug=66239&patch=fpm-syslog-bug.patch&revision=1386331016
 [2013-12-06 11:59 UTC] krakjoe@php.net
I think the first patch is correct, I don't see when you would want syslog expanded (usually to a non-existent path) in any case ...

Alternate patch attached anyway ...
 [2014-06-27 07:58 UTC] remi@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: remi
 [2014-06-27 07:58 UTC] remi@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

Fixed, see #67531
 [2014-07-11 10:45 UTC] emayoral at arsys dot es
Hi,

I have also been hit by this bug. Using php55-php-fpm from SCL on CentOS 6. 

Remi, since you are also the maintainer for those RPMs: Any idea when fresh official RPMs with this fix will be published?

Thanks.
 [2014-07-11 11:04 UTC] remi@php.net
@emayoral file a bug in RH bugzilla, perhaps it will be backported.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 01:03:35 2021 UTC