php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66198 gd extension fails to build with freetype 2.5.1
Submitted: 2013-11-29 06:29 UTC Modified: 2013-12-20 09:06 UTC
From: php-bugs-2013 at ryandesign dot com Assigned:
Status: Duplicate Package: GD related
PHP Version: 5.5.6 OS: OS X 10.9
Private report: No CVE-ID:
 [2013-11-29 06:29 UTC] php-bugs-2013 at ryandesign dot com
Description:
------------
With freetype 2.5.1, configuring php's gd extension fails to find 
freetype.h. This was reported to the MacPorts project here:

https://trac.macports.org/ticket/41585

The problem occurs because you're looking for the file here:

$PHP_FREETYPE_DIR/include/freetype2/freetype/freetype.h

but that's not where that file is located anymore as of freetype
2.5.1.

The freetype CHANGES file says, in part:


CHANGES BETWEEN 2.5 and 2.5.1

...

  II. IMPORTANT CHANGES

...

    - The header  file layout  has been changed.   After installation,
      all files are now located in `<prefix>/include/freetype2'.

      Applications  that  use   (a)  `freetype-config'  or  FreeType's
      `pkg-config' file to get the include directory for the compiler,
      and (b) the documented way for header inclusion like

        #include <ft2build.h>
        #include FT_FREETYPE_H
        ...

      don't need any change to the source code.


Bug #64405 requests you use pkg-config to find freetype.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-11 21:07 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 [2013-12-11 21:07 UTC] aharvey@php.net
Duplicate of bug #64405.
 [2013-12-20 03:21 UTC] vidurri at hotmail dot com
Solution in bug #66328 by Rafael Rocha Vidaurri

SOLUTION:
Let's search for the file on both directories replacing (on PHP "configure" file):
if test -f "$i/include/freetype2/freetype/freetype.h"; then

For:
if test -f "$i/include/freetype2/freetype/freetype.h" || test -f "$i/include/freetype2/freetype.h";  then


Bye ;)
 [2013-12-20 09:06 UTC] php-bugs-2013 at ryandesign dot com
Please use pkg-config instead.
 
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Tue Mar 03 15:01:52 2015 UTC