php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #66194 video stream rar fseek
Submitted: 2013-11-28 18:34 UTC Modified: 2017-07-27 03:30 UTC
Votes:2
Avg. Score:2.0 ± 1.0
Reproduced:0 of 0 (0.0%)
From: kh at ipimp dot at Assigned:
Status: Wont fix Package: rar (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2013-11-28 18:34 UTC] kh at ipimp dot at
Description:
------------
This is a script that could stream video content from a RAR archive
(comment line 59)

but because fseek is not supported, it will only play a few seconds of video.

Test script:
---------------
http://pastebin.com/UFgGLK8m


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-01 20:46 UTC] phpmpan at mpan dot pl
Exact copy of bug#60249.
 [2017-07-27 03:30 UTC] cataphract@php.net
-Status: Open +Status: Wont fix
 [2017-07-27 03:30 UTC] cataphract@php.net
This would not be practical to implement, as there's no way to jump to a certain offset the middle of the decompressed data, except maybe with solid archives. In any case, such functionality is not exposed by the unrar library.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Oct 31 16:01:24 2020 UTC