php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66189 pecl install jsonc fails during compilation
Submitted: 2013-11-28 00:54 UTC Modified: 2013-11-28 16:54 UTC
From: bugs dot php dot net at web dot wnsr dot net Assigned: remi (profile)
Status: Not a bug Package: PECL (PECL)
PHP Version: 5.5.6 OS: Ubuntu 12.04
Private report: No CVE-ID: None
 [2013-11-28 00:54 UTC] bugs dot php dot net at web dot wnsr dot net
Description:
------------
I am building a PHP 5.5.6 distribution for internal test use (we use various versions/flavours to regress our PHP app's unit tests against) on Ubuntu 12.04 (with latest updates); I excluded the 'json' extension when building PHP 5.5.6, and I am now attempting to 'pecl install jsonc', but it fails during compilation. I have installed other pecl extensions successfully (xdebug, imagick).



Test script:
---------------
php -v
php -m
php -i | grep ^Configure
sudo pecl install -o jsonc

Expected result:
----------------
I expect the jsonc extension to be downloaded, configured and installed by default.

Actual result:
--------------
$ php -v
PHP 5.5.6 (cli) (built: Nov 21 2013 15:15:47) 
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2013 Zend Technologies
    with Zend OPcache v7.0.3-dev, Copyright (c) 1999-2013, by Zend Technologies
    with Xdebug v2.2.3, Copyright (c) 2002-2013, by Derick Rethans

$ php -m
[PHP Modules]
bcmath
bz2
Core
ctype
date
dom
ereg
fileinfo
filter
gd
hash
iconv
imagick
libxml
mbstring
mhash
openssl
pcre
PDO
Phar
readline
Reflection
session
SimpleXML
SPL
standard
tokenizer
xdebug
xml
xmlreader
xmlwriter
Zend OPcache
zip
zlib

[Zend Modules]
Xdebug
Zend OPcache

$ php -i | grep ^Configure
Configure Command =>  './configure'  '--prefix=/opt/php-5.5.6-jsonc' '--with-config-file-path=/opt/php-5.5.6-jsonc/etc' '--with-config-file-scan-dir=/opt/php-5.5.6-jsonc/etc/php.ini.d' '--disable-all' '--with-iconv' '--enable-session' '--with-pear' '--enable-xml' '--enable-libxml' '--enable-ctype' '--enable-dom' '--enable-tokenizer' '--enable-simplexml' '--enable-xmlwriter' '--enable-xmlreader' '--enable-bcmath' '--enable-fileinfo' '--enable-filter' '--enable-hash' '--enable-mbstring' '--enable-opcache' '--enable-pdo' '--enable-phar' '--enable-zip' '--with-apxs2=/usr/bin/apxs2' '--with-bz2' '--with-gd' '--with-mhash' '--with-openssl' '--with-pcre-regex' '--with-readline' '--with-zlib'

$ sudo pecl install -o jsonc
downloading jsonc-1.3.2.tgz ...
Starting to download jsonc-1.3.2.tgz (61,768 bytes)
................done: 61,768 bytes
29 source files, building
WARNING: php_bin /opt/php-5.5.6-jsonc/bin/php appears to have a suffix -5.5.6-jsonc/bin/php, but config variable php_suffix does not match
running: phpize
Configuring for:
PHP Api Version:         20121113
Zend Module Api No:      20121212
Zend Extension Api No:   220121212
building in /tmp/pear/temp/pear-build-rootoW8Gh4/jsonc-1.3.2
running: /tmp/pear/temp/jsonc/configure
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /opt/php-5.5.6-jsonc
checking for PHP includes... -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib
checking for PHP extension directory... /opt/php-5.5.6-jsonc/lib/php/extensions/no-debug-non-zts-20121212
checking for PHP installed headers prefix... /opt/php-5.5.6-jsonc/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking whether to enable JavaScript Object Serialization support... yes, shared
checking whether to rename module file to jsonc... no
checking libjson... no
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking for ANSI C header files... (cached) yes
checking for working sscanf... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking for strings.h... (cached) yes
checking syslog.h usability... yes
checking syslog.h presence... yes
checking for syslog.h... yes
checking for unistd.h... (cached) yes
checking sys/param.h usability... yes
checking sys/param.h presence... yes
checking for sys/param.h... yes
checking stdarg.h usability... yes
checking stdarg.h presence... yes
checking for stdarg.h... yes
checking for inttypes.h... (cached) yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for strcasecmp... yes
checking for strdup... yes
checking for strndup... yes
checking for strerror... yes
checking for snprintf... yes
checking for vsnprintf... yes
checking for vasprintf... yes
checking for open... yes
checking for vsyslog... yes
checking for strncasecmp... yes
checking for setlocale... yes
checking JSON extension name:... json
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 1572864
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/bash /tmp/pear/temp/pear-build-rootoW8Gh4/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/pear/temp/jsonc -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-rootoW8Gh4/jsonc-1.3.2/include -I/tmp/pear/temp/pear-build-rootoW8Gh4/jsonc-1.3.2/main -I/tmp/pear/temp/jsonc -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/jsonc/json.c -o json.lo
mkdir .libs
 cc -I. -I/tmp/pear/temp/jsonc -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-rootoW8Gh4/jsonc-1.3.2/include -I/tmp/pear/temp/pear-build-rootoW8Gh4/jsonc-1.3.2/main -I/tmp/pear/temp/jsonc -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/jsonc/json.c  -fPIC -DPIC -o .libs/json.o
/bin/bash /tmp/pear/temp/pear-build-rootoW8Gh4/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/pear/temp/jsonc -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-rootoW8Gh4/jsonc-1.3.2/include -I/tmp/pear/temp/pear-build-rootoW8Gh4/jsonc-1.3.2/main -I/tmp/pear/temp/jsonc -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/jsonc/json-c/arraylist.c -o json-c/arraylist.lo
/tmp/pear/temp/pear-build-rootoW8Gh4/jsonc-1.3.2/libtool: line 1283: json-c/arraylist.loT: No such file or directory
mkdir json-c/.libs
mkdir: cannot create directory `json-c/.libs': No such file or directory
make: *** [json-c/arraylist.lo] Error 1
ERROR: `make' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-11-28 01:00 UTC] aharvey@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: remi
 [2013-11-28 01:00 UTC] aharvey@php.net
Assigning to Remi, since we don't seem to have a jsonc package for some reason.
 [2013-11-28 06:05 UTC] remi@php.net
can you try the manual way ?

pecl download jsonc
tar xf jsonc-1.3.2.tgz
cd jsonc-1.3.2
phpize
./configure
make
 [2013-11-28 16:35 UTC] bugs dot php dot net at web dot wnsr dot net
Trying the manual way works:

$ pecl download jsonc
downloading jsonc-1.3.2.tgz ...
Starting to download jsonc-1.3.2.tgz (61,768 bytes)
................done: 61,768 bytes
File /tmp/jsonc-1.3.2.tgz downloaded

$ tar xf jsonc-1.3.2.tgz 

$ cd jsonc-1.3.2/

$ phpize
Configuring for:
PHP Api Version:         20121113
Zend Module Api No:      20121212
Zend Extension Api No:   220121212

$ ./configure
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /opt/php-5.5.6-jsonc
checking for PHP includes... -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib
checking for PHP extension directory... /opt/php-5.5.6-jsonc/lib/php/extensions/no-debug-non-zts-20121212
checking for PHP installed headers prefix... /opt/php-5.5.6-jsonc/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking whether to enable JavaScript Object Serialization support... yes, shared
checking whether to rename module file to jsonc... no
checking libjson... no
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking for ANSI C header files... (cached) yes
checking for working sscanf... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking for strings.h... (cached) yes
checking syslog.h usability... yes
checking syslog.h presence... yes
checking for syslog.h... yes
checking for unistd.h... (cached) yes
checking sys/param.h usability... yes
checking sys/param.h presence... yes
checking for sys/param.h... yes
checking stdarg.h usability... yes
checking stdarg.h presence... yes
checking for stdarg.h... yes
checking for inttypes.h... (cached) yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for strcasecmp... yes
checking for strdup... yes
checking for strndup... yes
checking for strerror... yes
checking for snprintf... yes
checking for vsnprintf... yes
checking for vasprintf... yes
checking for open... yes
checking for vsyslog... yes
checking for strncasecmp... yes
checking for setlocale... yes
checking JSON extension name:... json
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 1572864
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h

$ make
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/jsonc-1.3.2/json.c -o json.lo 
mkdir .libs
 cc -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/jsonc-1.3.2/json.c  -fPIC -DPIC -o .libs/json.o
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/jsonc-1.3.2/json-c/arraylist.c -o json-c/arraylist.lo 
mkdir json-c/.libs
 cc -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/jsonc-1.3.2/json-c/arraylist.c  -fPIC -DPIC -o json-c/.libs/arraylist.o
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/jsonc-1.3.2/json-c/debug.c -o json-c/debug.lo 
 cc -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/jsonc-1.3.2/json-c/debug.c  -fPIC -DPIC -o json-c/.libs/debug.o
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/jsonc-1.3.2/json-c/json_c_version.c -o json-c/json_c_version.lo 
 cc -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/jsonc-1.3.2/json-c/json_c_version.c  -fPIC -DPIC -o json-c/.libs/json_c_version.o
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/jsonc-1.3.2/json-c/json_object.c -o json-c/json_object.lo 
 cc -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/jsonc-1.3.2/json-c/json_object.c  -fPIC -DPIC -o json-c/.libs/json_object.o
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/jsonc-1.3.2/json-c/json_object_iterator.c -o json-c/json_object_iterator.lo 
 cc -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/jsonc-1.3.2/json-c/json_object_iterator.c  -fPIC -DPIC -o json-c/.libs/json_object_iterator.o
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/jsonc-1.3.2/json-c/json_tokener.c -o json-c/json_tokener.lo 
 cc -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/jsonc-1.3.2/json-c/json_tokener.c  -fPIC -DPIC -o json-c/.libs/json_tokener.o
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/jsonc-1.3.2/json-c/json_util.c -o json-c/json_util.lo 
 cc -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/jsonc-1.3.2/json-c/json_util.c  -fPIC -DPIC -o json-c/.libs/json_util.o
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/jsonc-1.3.2/json-c/linkhash.c -o json-c/linkhash.lo 
 cc -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/jsonc-1.3.2/json-c/linkhash.c  -fPIC -DPIC -o json-c/.libs/linkhash.o
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=compile cc  -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/jsonc-1.3.2/json-c/printbuf.c -o json-c/printbuf.lo 
 cc -I. -I/tmp/jsonc-1.3.2 -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/jsonc-1.3.2/json-c/printbuf.c  -fPIC -DPIC -o json-c/.libs/printbuf.o
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=link cc -DPHP_ATOM_INC -I/tmp/jsonc-1.3.2/include -I/tmp/jsonc-1.3.2/main -I/tmp/jsonc-1.3.2 -I/opt/php-5.5.6-jsonc/include/php -I/opt/php-5.5.6-jsonc/include/php/main -I/opt/php-5.5.6-jsonc/include/php/TSRM -I/opt/php-5.5.6-jsonc/include/php/Zend -I/opt/php-5.5.6-jsonc/include/php/ext -I/opt/php-5.5.6-jsonc/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -o json.la -export-dynamic -avoid-version -prefer-pic -module -rpath /tmp/jsonc-1.3.2/modules  json.lo json-c/arraylist.lo json-c/debug.lo json-c/json_c_version.lo json-c/json_object.lo json-c/json_object_iterator.lo json-c/json_tokener.lo json-c/json_util.lo json-c/linkhash.lo json-c/printbuf.lo 
cc -shared  .libs/json.o json-c/.libs/arraylist.o json-c/.libs/debug.o json-c/.libs/json_c_version.o json-c/.libs/json_object.o json-c/.libs/json_object_iterator.o json-c/.libs/json_tokener.o json-c/.libs/json_util.o json-c/.libs/linkhash.o json-c/.libs/printbuf.o   -Wl,-soname -Wl,json.so -o .libs/json.so
creating json.la
(cd .libs && rm -f json.la && ln -s ../json.la json.la)
/bin/bash /tmp/jsonc-1.3.2/libtool --mode=install cp ./json.la /tmp/jsonc-1.3.2/modules
cp ./.libs/json.so /tmp/jsonc-1.3.2/modules/json.so
cp ./.libs/json.lai /tmp/jsonc-1.3.2/modules/json.la
PATH="$PATH:/sbin" ldconfig -n /tmp/jsonc-1.3.2/modules
----------------------------------------------------------------------
Libraries have been installed in:
   /tmp/jsonc-1.3.2/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------

Build complete.
Don't forget to run 'make test'.
 [2013-11-28 16:54 UTC] remi@php.net
OK, so something wrong in your environment and sudo usage.
Closing.
 [2013-11-28 16:54 UTC] remi@php.net
-Status: Assigned +Status: Not a bug
 [2013-11-28 16:54 UTC] remi@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 10:01:24 2020 UTC