php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66149 PHP 5.4 snapshots broken after branching PHP 5.6
Submitted: 2013-11-22 16:47 UTC Modified: 2013-12-01 22:34 UTC
From: neweracracker at gmail dot com Assigned: derick (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
 [2013-11-22 16:47 UTC] neweracracker at gmail dot com
Description:
------------
php5.4-201311221630.tar.xz

cat main/php_version.h
/* automatically generated by configure */
/* edit configure.in to change version number */
#define PHP_MAJOR_VERSION 5
#define PHP_MINOR_VERSION 6
#define PHP_RELEASE_VERSION 0
#define PHP_EXTRA_VERSION "-dev"
#define PHP_VERSION "5.6.0-dev"
#define PHP_VERSION_ID 50600



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-11-24 10:11 UTC] felipe@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: dsp
 [2013-11-24 17:28 UTC] dsp@php.net
-Assigned To: dsp +Assigned To: tyrael
 [2013-11-25 15:17 UTC] tyrael@php.net
-Status: Assigned +Status: Verified
 [2013-11-25 15:17 UTC] tyrael@php.net
waiting for my account for the snaps box to be able to debug the issue.
it seems that we are building the 5.4 archive from the 5.6 branch.
 [2013-11-28 16:22 UTC] derick@php.net
-Status: Verified +Status: Feedback
 [2013-11-28 16:22 UTC] derick@php.net
Please try using this snapshot:

  http://snaps.php.net/php-trunk-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/

This should be fixed now!
 [2013-11-28 19:20 UTC] neweracracker at gmail dot com
Downloaded

php5.4-201311281830.tar.xz

Same problem
 [2013-11-30 15:30 UTC] neweracracker at gmail dot com
-Status: Feedback +Status: Assigned
 [2013-11-30 15:30 UTC] neweracracker at gmail dot com
Any news on this?
 [2013-11-30 19:14 UTC] bjori@php.net
-Assigned To: tyrael +Assigned To: derick
 [2013-11-30 19:14 UTC] bjori@php.net
Derick, the 5.4 snapshot is indeed the wrong branch (5.6-dev)

The 5.3, 5.5 and 5.6 all seem correct
 [2013-12-01 22:33 UTC] derick@php.net
-Status: Assigned +Status: Feedback
 [2013-12-01 22:33 UTC] derick@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.4-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/

Okay, really fixed now. It was on the right branch, but something was really out with the clone. I've recloned and tested the generation. It looks all ok to me now:

derick@whisky:/tmp $ cd php5.4-201312012223/

derick@whisky:/tmp/php5.4-201312012223 $ cat main/php_version.h 
/* automatically generated by configure */
/* edit configure.in to change version number */
#define PHP_MAJOR_VERSION 5
#define PHP_MINOR_VERSION 4
#define PHP_RELEASE_VERSION 24
 [2013-12-01 22:34 UTC] derick@php.net
-Status: Feedback +Status: Closed
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 04:01:25 2019 UTC