php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66081 Error with decimals
Submitted: 2013-11-12 16:14 UTC Modified: 2013-11-12 16:21 UTC
From: ffernandez at sidetours dot com Assigned:
Status: Not a bug Package: Math related
PHP Version: Irrelevant OS: Windows 7
Private report: No CVE-ID: None
 [2013-11-12 16:14 UTC] ffernandez at sidetours dot com
Description:
------------
---
From manual page: http://www.php.net/function.ceil#refsect1-function.ceil-description
---

(36.77 * 100) == 3677
ceil(36.77 * 100) == 3678   // Should be 3677



Test script:
---------------
<?php
echo "(36.77 * 100) == ".(36.77 * 100)."<br />\n";
echo "ceil(36.77 * 100) == ".ceil(36.77 * 100)."<br />\n";
?>

Expected result:
----------------
(36.77 * 100) == 3677
ceil(36.77 * 100) == 3677

Actual result:
--------------
ceil(36.77 * 100) == 3678

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-11-12 16:21 UTC] derick@php.net
-Status: Open +Status: Not a bug
 [2013-11-12 16:21 UTC] derick@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 29 06:01:28 2020 UTC