php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6605 missing file: "os-inline.c"
Submitted: 2000-09-07 12:25 UTC Modified: 2000-10-19 19:22 UTC
From: f dot scharfenorth at bv dot tu-berlin dot de Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.0.1pl2 OS: AIX 4.3
Private report: No CVE-ID: None
 [2000-09-07 12:25 UTC] f dot scharfenorth at bv dot tu-berlin dot de
I always had problems with compiling the php-modul for AIX, usually I included mysql-support cause it caused problems with previously differently declared variables, so I disabled mysql support and now I get these error-messages:

>./configure --with-apxs=/usr/HTTPServer/bin/apxs --without-mysql
>make
>make install
...
Target "install" is up to date.
Making install in sapi
Making install in apache
        /bin/sh /home/frank/downloads/php-4.0.1pl2/libtool --silent --mode=compile gcc -DHAVE_CONFIG_H -I. -I/home/frank/downloads/php-4.0.1pl2/sapi/apache -I/home/frank/downloads/php-4.0.1pl2 -I/home/frank/downloads/php-4.0.1pl2/main -I/usr/HTTPServer/include -I/home/frank/downloads/php-4.0.1pl2/Zend -I/home/frank/downloads/php-4.0.1pl2 -I/home/frank/downloads/php-4.0.1pl2/ext/xml/expat/xmltok -I/home/frank/downloads/php-4.0.1pl2/ext/xml/expat/xmlparse  -DXML_BYTE_ORDER=21 -O2  -c sapi_apache.c
In file included from /usr/HTTPServer/include/ap_config.h:115,
                 from /usr/HTTPServer/include/httpd.h:71,
                 from sapi_apache.c:32:
/usr/HTTPServer/include/os.h:79: os-inline.c: No such file or directory
make: 1254-004 The error code from the last command is 1.
Stop.
make: 1254-004 The error code from the last command is 1.
Stop.
make: 1254-004 The error code from the last command is 1.
Stop.
make: 1254-004 The error code from the last command is 1.
Stop.


Any ideas?:)
Thanks for your help
F.S.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-13 22:19 UTC] sniper@php.net
Have you tried PHP4.0.3? Does this problem exist in it?

--Jani
 [2000-10-19 09:42 UTC] f dot scharfenorth at bv dot tu-berlin dot de
I downloaded the latest sources of php and additionally I unzipped the sources of the apache (which were in the directory "apachesrc", cause I compiled the php-module for the IBM-HTTTPServer based on the apache!) and then the os-inline.c was found. Then I ran into the problem of "Bug id #2287", but with the little adjustment (->check #2287) I could finally compile the modul and the webserver runs now with that modul - well, I haven't had much time to do a lot of testing - but the <?phpinfo()?> works fine!
Thank for your help!
CU
Frank
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 26 03:03:35 2021 UTC