php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66007 Cannot compile PHP shared modules in FreeBSD 10 due to detection of freebsd1*
Submitted: 2013-10-30 23:28 UTC Modified: 2014-10-01 21:07 UTC
Votes:21
Avg. Score:4.6 ± 0.7
Reproduced:21 of 21 (100.0%)
Same Version:1 (4.8%)
Same OS:7 (33.3%)
From: alexyam at live dot com Assigned:
Status: Duplicate Package: *Compile Issues
PHP Version: 5.5.5 OS: FreeBSD 10
Private report: No CVE-ID: None
 [2013-10-30 23:28 UTC] alexyam at live dot com
Description:
------------
Tested PHP 5.5.5 on a FreeBSD 10 Beta 2 box. Turned out all php modules were compiled static only.

Traced problem to the configure script:
checking if libtool supports shared libraries... no
checking whether to build shared libraries... no

Solution: Edit 3 files to remove checks for freebsd1* (which was supposed to check FreeBSD version 1.*)


------------------------------------------
aclocal.m4 line 4549:
------------------------------------------
freebsd1*)
  dynamic_linker=no
  ;;

------------------------------------------
aclocal.m4 line 8860:
------------------------------------------
    freebsd1*)
      _LT_AC_TAGVAR(ld_shlibs, $1)=no
      ;;

------------------------------------------
configure line 108005:
------------------------------------------
    freebsd1*)
      ld_shlibs=no
      ;;

------------------------------------------
configure line 108654:
------------------------------------------
freebsd1*)
  dynamic_linker=no
  ;;

------------------------------------------
configure line 112291:
------------------------------------------
freebsd1*)
  dynamic_linker=no
  ;;

------------------------------------------
/build/libtool.m4 line 1535:
------------------------------------------
freebsd1*)
  dynamic_linker=no
  ;;

------------------------------------------
/build/libtool.m4 line 5846:
------------------------------------------
    freebsd1*)
      _LT_AC_TAGVAR(ld_shlibs, $1)=no
      ;;
------------------------------------------

git diff patch included.



Test script:
---------------
./configure

Expected result:
----------------
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes

Actual result:
--------------
checking if libtool supports shared libraries... no
checking whether to build shared libraries... no

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-30 23:38 UTC] alexyam at live dot com
Got an "Cannot create patch storage for Bug" error when uploading git diff, pasting it here instead:

diff --git a/./php-5.5.5/aclocal.m4 b/./php-5.5.5-patched/aclocal.m4
index be8cbb5..9c326bc 100644
--- a/./php-5.5.5/aclocal.m4
+++ b/./php-5.5.5-patched/aclocal.m4
@@ -4546,7 +4546,7 @@ dgux*)
   shlibpath_var=LD_LIBRARY_PATH
   ;;
 
-freebsd1*)
+freebsd1.*)
   dynamic_linker=no
   ;;
 
@@ -8857,7 +8857,7 @@ _LT_EOF
       _LT_AC_TAGVAR(hardcode_shlibpath_var, $1)=no
       ;;
 
-    freebsd1*)
+    freebsd1.*)
       _LT_AC_TAGVAR(ld_shlibs, $1)=no
       ;;
 
diff --git a/./php-5.5.5/build/libtool.m4 b/./php-5.5.5-patched/build/libtool.m4
index 56658cc..627864c 100644
--- a/./php-5.5.5/build/libtool.m4
+++ b/./php-5.5.5-patched/build/libtool.m4
@@ -1532,7 +1532,7 @@ dgux*)
   shlibpath_var=LD_LIBRARY_PATH
   ;;
 
-freebsd1*)
+freebsd1.*)
   dynamic_linker=no
   ;;
 
@@ -5843,7 +5843,7 @@ _LT_EOF
       _LT_AC_TAGVAR(hardcode_shlibpath_var, $1)=no
       ;;
 
-    freebsd1*)
+    freebsd1.*)
       _LT_AC_TAGVAR(ld_shlibs, $1)=no
       ;;
 
diff --git a/./php-5.5.5/configure b/./php-5.5.5-patched/configure
index 0ee9884..7572c3f 100755
--- a/./php-5.5.5/configure
+++ b/./php-5.5.5-patched/configure
@@ -108002,7 +108002,7 @@ if test -z "$aix_libpath"; then aix_libpath="/usr/lib:/lib"; fi
       hardcode_shlibpath_var=no
       ;;
 
-    freebsd1*)
+    freebsd1.*)
       ld_shlibs=no
       ;;
 
@@ -108651,7 +108651,7 @@ dgux*)
   shlibpath_var=LD_LIBRARY_PATH
   ;;
 
-freebsd1*)
+freebsd1.*)
   dynamic_linker=no
   ;;
 
@@ -112288,7 +112288,7 @@ dgux*)
   shlibpath_var=LD_LIBRARY_PATH
   ;;
 
-freebsd1*)
+freebsd1.*)
   dynamic_linker=no
   ;;
 [2014-02-19 07:48 UTC] bscott99 at bunytech dot com dot au
Other freebsd version 10 / version 1 errors exist in the same files.

--- aclocal.m4.orig	2014-02-05 21:05:05.000000000 +1100
+++ aclocal.m4	2014-02-19 18:40:49.000000000 +1100
@@ -4546,7 +4546,7 @@
   shlibpath_var=LD_LIBRARY_PATH
   ;;
 
-freebsd1*)
+freebsd1.*)
   dynamic_linker=no
   ;;
 
@@ -4557,7 +4557,7 @@
     objformat=`/usr/bin/objformat`
   else
     case $host_os in
-    freebsd[[123]]*) objformat=aout ;;
+    freebsd[[123]].*) objformat=aout ;;
     *) objformat=elf ;;
     esac
   fi
@@ -6174,7 +6174,7 @@
 	;;
     esac
     ;;
-  freebsd[[12]]*)
+  freebsd[[12]].*)
     # C++ shared libraries reported to be fairly broken before switch to ELF
     _LT_AC_TAGVAR(ld_shlibs, $1)=no
     ;;
@@ -8857,7 +8857,7 @@
       _LT_AC_TAGVAR(hardcode_shlibpath_var, $1)=no
       ;;
 
-    freebsd1*)
+    freebsd1.*)
       _LT_AC_TAGVAR(ld_shlibs, $1)=no
       ;;
 
--- configure.orig	2014-02-05 21:05:08.000000000 +1100
+++ configure	2014-02-19 18:40:49.000000000 +1100
@@ -107703,7 +107703,7 @@
       hardcode_shlibpath_var=no
       ;;
 
-    freebsd1*)
+    freebsd1.*)
       ld_shlibs=no
       ;;
 
@@ -108352,7 +108352,7 @@
   shlibpath_var=LD_LIBRARY_PATH
   ;;
 
-freebsd1*)
+freebsd1.*)
   dynamic_linker=no
   ;;
 
@@ -108363,7 +108363,7 @@
     objformat=`/usr/bin/objformat`
   else
     case $host_os in
-    freebsd[123]*) objformat=aout ;;
+    freebsd[123].*) objformat=aout ;;
     *) objformat=elf ;;
     esac
   fi
@@ -110443,7 +110443,7 @@
 	;;
     esac
     ;;
-  freebsd[12]*)
+  freebsd[12].*)
     # C++ shared libraries reported to be fairly broken before switch to ELF
     ld_shlibs_CXX=no
     ;;
@@ -111989,7 +111989,7 @@
   shlibpath_var=LD_LIBRARY_PATH
   ;;
 
-freebsd1*)
+freebsd1.*)
   dynamic_linker=no
   ;;
 
@@ -112000,7 +112000,7 @@
     objformat=`/usr/bin/objformat`
   else
     case $host_os in
-    freebsd[123]*) objformat=aout ;;
+    freebsd[123].*) objformat=aout ;;
     *) objformat=elf ;;
     esac
   fi
--- build/libtool.m4.orig	2014-02-05 21:00:36.000000000 +1100
+++ build/libtool.m4	2014-02-19 18:40:49.000000000 +1100
@@ -1532,7 +1532,7 @@
   shlibpath_var=LD_LIBRARY_PATH
   ;;
 
-freebsd1*)
+freebsd1.*)
   dynamic_linker=no
   ;;
 
@@ -1543,7 +1543,7 @@
     objformat=`/usr/bin/objformat`
   else
     case $host_os in
-    freebsd[[123]]*) objformat=aout ;;
+    freebsd[[123]].*) objformat=aout ;;
     *) objformat=elf ;;
     esac
   fi
@@ -3160,7 +3160,7 @@
 	;;
     esac
     ;;
-  freebsd[[12]]*)
+  freebsd[[12]].*)
     # C++ shared libraries reported to be fairly broken before switch to ELF
     _LT_AC_TAGVAR(ld_shlibs, $1)=no
     ;;
@@ -5843,7 +5843,7 @@
       _LT_AC_TAGVAR(hardcode_shlibpath_var, $1)=no
       ;;
 
-    freebsd1*)
+    freebsd1.*)
       _LT_AC_TAGVAR(ld_shlibs, $1)=no
       ;;
 [2014-10-01 21:07 UTC] tyrael@php.net
-Status: Open +Status: Duplicate
 [2014-10-01 21:07 UTC] tyrael@php.net
Duplicate of #67091 (this was reported sooner, but somehow went under the radar). the fix was released with 5.4.31, 5.5.15 and 5.6.0.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 20 01:01:23 2020 UTC