php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65953 LUA 5.1 build
Submitted: 2013-10-23 17:19 UTC Modified: 2017-08-08 04:12 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: remi@php.net Assigned: laruence (profile)
Status: Closed Package: lua (PECL)
PHP Version: 5.5.5 OS: GNU/Linux (Fedora 19)
Private report: No CVE-ID: None
 [2013-10-23 17:19 UTC] remi@php.net
Description:
------------
Is LUA 5.1 still supported.

Build fails for 2 undefined constant : LUA_OK and LUA_ERRGCMM

Proposal for LUA_OK

#ifndef LUA_OK
#define LUA_OK 0
#endif

Proposal for LUA_ERRGCMM
#ifdef LUA_ERRGCMM
	REGISTER_LONG_CONSTANT("LUA_ERRGCMM", LUA_ERRGCMM, CONST_PERSISTENT | CONST_CS);
#endif



P.S. I haven't found the official sources repo.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-23 17:21 UTC] remi@php.net
With those proposal, build is ok.

2 minor problems in test suite because of different error messages.

$ cat tests/001.diff
003+ [string "line"]:1: '=' expected near 'code'
003- [string "line"]:1: syntax error near 'code'

$ cat tests/001.diff
003+ [string "line"]:1: '=' expected near 'code'
003- [string "line"]:1: syntax error near 'code'[remi@schrodingerscat lua-1.1.0 (master)]$ cat tests/006.diff
005+ ...pmbuild/SPECS/remirepo/php/pecl/php-pecl-lua/lua-1.1.0/tests/006.php.tmp:1: '=' expected near 'fdrg'
005- %s:%d: syntax error near 'fdrg'
 [2017-07-28 09:02 UTC] kalle@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: laruence
 [2017-07-28 09:02 UTC] kalle@php.net
It seems like the package is active, maybe Xinchen can give us some insight whether or not to fix it like this
 [2017-08-08 04:12 UTC] laruence@php.net
-Status: Assigned +Status: Closed
 [2017-08-08 04:12 UTC] laruence@php.net
this should already be fixed in release
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jul 05 14:01:39 2020 UTC