php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #65899 Doc typo
Submitted: 2013-10-15 09:41 UTC Modified: 2013-12-31 21:03 UTC
Votes:1
Avg. Score:2.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: php at javierabr dot eu Assigned: frozenfire (profile)
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2013-10-15 09:41 UTC] php at javierabr dot eu
Description:
------------
---
From manual page: http://www.php.net/function.property-exists#refsect1-function.property-exists-description
---
At the description: "A diferencia dedevuelve isset()", 

it should be:

"A diferencia de isset()"

Expected result:
----------------
A diferencia de isset()

Actual result:
--------------
A diferencia dedevuelve isset()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-31 20:00 UTC] frozenfire@php.net
Automatic comment from SVN on behalf of frozenfire
Revision: http://svn.php.net/viewvc/?view=revision&revision=332547
Log: Fixed typo in translation.
Fixes bug #65899.
 [2013-12-31 20:01 UTC] frozenfire@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: frozenfire
 [2013-12-31 20:01 UTC] frozenfire@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 [2013-12-31 20:25 UTC] php at javierabr dot eu
-Status: Closed +Status: Assigned
 [2013-12-31 20:25 UTC] php at javierabr dot eu
Bug is not fixed, it must read "A diferencia de isset,"; not "A diferencia de vuelve isset" as typed by frozenfire at revision 332547:
(Believe me, I'm a native spanish, but don't know yet how to make patches by myself)
-------------------------------------------------------------

--- phpdoc/es/trunk/reference/classobj/functions/property-exists.xml	2013/12/31 18:39:55	332546
+++ phpdoc/es/trunk/reference/classobj/functions/property-exists.xml	2013/12/31 20:00:54	332547
@@ -21,7 +21,7 @@
   </para>
   <note>
    <para>
-    A diferencia dedevuelve <function>isset</function>,
+    A diferencia de vuelve <function>isset</function>,
     <function>property_exists</function> devuelve &true; incluso si la propiedad
     tiene el valor &null;.
    </para>

-------------------------------------------------------------
It should be:

--- phpdoc/es/trunk/reference/classobj/functions/property-exists.xml	2013/12/31 18:39:55	332546
+++ phpdoc/es/trunk/reference/classobj/functions/property-exists.xml	2013/12/31 20:00:54	332547
@@ -21,7 +21,7 @@
   </para>
   <note>
    <para>
-    A diferencia dedevuelve <function>isset</function>,
+    A diferencia de <function>isset</function>,
     <function>property_exists</function> devuelve &true; incluso si la propiedad
     tiene el valor &null;.
    </para>
 [2013-12-31 21:01 UTC] frozenfire@php.net
Automatic comment from SVN on behalf of frozenfire
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=332549
Log: Changed de vuelve to de, per native speaker's advice.
Fixes bug #65899.
 [2013-12-31 21:03 UTC] frozenfire@php.net
-Status: Assigned +Status: Closed
 [2013-12-31 21:03 UTC] frozenfire@php.net
Sorry, had thought maybe the original translator just made a typo, so I picked what was closest to the original text and translated well. :)

I've changed it per your advice. If you would like to contribute your own bugfixes and translations, please feel free to join #php.doc on EFNet IRC, and I'll get you started.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 08:03:14 2021 UTC