|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #65785 mbstring.func_overload should be depreciated.
Submitted: 2013-09-29 13:12 UTC Modified: 2017-07-22 15:35 UTC
Avg. Score:4.8 ± 0.6
Reproduced:18 of 19 (94.7%)
Same Version:10 (55.6%)
Same OS:9 (50.0%)
From: sasezaki at gmail dot com Assigned: nikic (profile)
Status: Closed Package: mbstring related
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
 [2013-09-29 13:12 UTC] sasezaki at gmail dot com
func_overload ( )
should be depricated.

Nowadays, mbstring.func_overload is often set based on misunderstood. And it 
causes strlen() is not bytesize issue.


This feature is like "register_globals".

Already, I contact to Japanese PHP Developers ML(*1), & mbstring maintainer - 
Rui Hirokawa agreed this feature should be depricated.
And He suggested that I must open bug issue report. 


Test script:
php -d mbstring.func_overload=2 -r "var_dump((int)ini_get('mbstring.func_overload') & 2);

Expected result:
should be raised "PHP Deprecated: mbstring.func_overload is depricated, "  

Actual result:


Add a Patch

Pull Requests

Pull requests:

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2015-05-21 15:02 UTC] dsxack at gmail dot com
mbstring.func_overload - a feature that prevents the development of eco-system php. Due to the fact that the popular vendors decide to support the expansion of mbstring and feature mbstring.func_overload or not - many products are incompatible. Simfony requires mbstring.func_overload disabled features in all its products (, while others may require the inclusion (for example - the most popular CMS in Russia - Bitrix). Because of this library simfony cease to be compatible with the products Bitrix. I believe that mbstring.func_overload - this is one of the most horrible things that have at the moment in PHP.
 [2017-07-22 15:35 UTC]
-Status: Open +Status: Closed -Assigned To: +Assigned To: nikic
 [2017-07-22 15:35 UTC]
mbstring.func_overload has been deprecated in PHP 7.2.
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC