php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65773 Unable to install mcrypt
Submitted: 2013-09-27 11:50 UTC Modified: 2013-09-27 18:49 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: vivek at csillamvilag dot com Assigned:
Status: Not a bug Package: mcrypt related
PHP Version: 5.5.4 OS: CentOS 6.4
Private report: No CVE-ID: None
 [2013-09-27 11:50 UTC] vivek at csillamvilag dot com
Description:
------------
Installation of mcrypts crashes, ostensibly due to unavailability of glibc 2.14

CentOS ships with glibc 2.12 and PHP 5.3.3

Has mcrypt or libmcrypt changed so much since PHP 5.3.3 that there is a dependency 
on glibc 2.14? If so, this dependency is not mentioned anywhere in documentation.

mcrypt's only mentioned dependency is as below
http://www.php.net/manual/en/mcrypt.requirements.php
PHP mcrypt module requires libmcrypt 2.5.6 or later

Test script:
---------------
We have tried the following methods,

1. Re configured PHP using option --with-mcrypt
2. Make install from directory /usr/local/src/php-5.5.4/ext/mcrypt
3. yum install php-mcrypt
4. Manually installing the extension using /usr/local/src/php-mcrypt-5.5.4-1-x86_64.pkg.tar.xz

Expected result:
----------------
The latest version of CentOS, i.e. 6.4 ships with glibc 2.12

I would expect to be able to install mcrypt with glibc 2.12

Actual result:
--------------
PHP Warning: PHP Startup: Unable to load dynamic library 
'/usr/lib/php/extensions/no-debug-non-zts-20121212/mcrypt.so' - /lib64/libc.so.6: 
version `GLIBC_2.14' not found (required by /usr/lib/php/extensions/no-debug-non-
zts-20121212/mcrypt.so)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-09-27 18:49 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2013-09-27 18:49 UTC] aharvey@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Your mcrypt.so is incompatible with your libc, which suggests that it wasn't 
built on the same system as you're trying to install it on.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Aug 02 22:01:23 2021 UTC