php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #65753 JsonSerializeable couldn't implement on module extension.
Submitted: 2013-09-24 13:15 UTC Modified: 2014-02-17 10:01 UTC
From: chobieeee@php.net Assigned: jpauli
Status: Closed Package: json (PECL)
PHP Version: 5.5.4 OS:
Private report: No CVE-ID:
 [2013-09-24 13:15 UTC] chobieeee@php.net
Description:
------------
php_json_serializable_ce couldn't see from dynamic loaded extension as it doesn't 
specified PHP_JSON_API. this means it can't implement JsonSerializeable interface 
on another extension.

Other extension could use same json serialize interface.

see this thread: http://marc.info/?l=php-internals&m=137856864818778&w=2

Expected result:
----------------
other extension could implement JsonSerializeable interface as well as userland 
php code.


Patches

export-json-serializeable-ce.patch (last revision 2013-09-24 13:16 UTC) by chobieeee@php.net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-09-24 13:16 UTC] chobieeee@php.net
The following patch has been added/updated:

Patch Name: export-json-serializeable-ce.patch
Revision:   1380028565
URL:        https://bugs.php.net/patch-display.php?bug=65753&patch=export-json-serializeable-ce.patch&revision=1380028565
 [2014-02-17 10:01 UTC] jpauli@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: jpauli
 [2014-02-17 10:01 UTC] jpauli@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

This has been fixed from 5.4 branch
 
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Mon Jun 15 18:01:54 2015 UTC