php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65720 ext/mbstring/libmbfl/filters/mbfilter_cp5022x.c:281: bad if test ?
Submitted: 2013-09-20 08:54 UTC Modified: 2013-09-20 21:24 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: dcb314 at hotmail dot com Assigned:
Status: Closed Package: mbstring related
PHP Version: 5.5.4 OS: linux
Private report: No CVE-ID: None
 [2013-09-20 08:54 UTC] dcb314 at hotmail dot com
Description:
------------
I just ran static analyser "cppcheck" over the source code
of php-5.5.3

It said

[/home/dcb/rpmbuild/BUILD/php-5.5.3/ext/mbstring/libmbfl/filters/mbfilter_cp5022x.c:281]: (warning) Logical conjunction always evaluates to false: s < 8648 && s >= 10716.

This looks like a copy'n'paste error to me.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-09-20 21:24 UTC] aharvey@php.net
-Package: Compile Warning +Package: mbstring related
 [2016-01-18 01:53 UTC] yohgaki@php.net
Automatic comment on behalf of yohgaki
Revision: http://git.php.net/?p=php-src.git;a=commit;h=dc23f1f38f649f9a42ebd70e7301462779f82935
Log: Fixed bug #65720 ext/mbstring/libmbfl/filters/mbfilter_cp5022x.c:281: bad if test
 [2016-01-18 01:53 UTC] yohgaki@php.net
-Status: Open +Status: Closed
 [2016-01-18 01:56 UTC] yohgaki@php.net
Automatic comment on behalf of yohgaki
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f9c595f3c07c4a8671fe751d97cd58cc4c2d337c
Log: Fixed bug #65720 ext/mbstring/libmbfl/filters/mbfilter_cp5022x.c:281: bad if test
 [2016-01-18 04:37 UTC] yohgaki@php.net
Automatic comment on behalf of yohgaki
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f9c595f3c07c4a8671fe751d97cd58cc4c2d337c
Log: Fixed bug #65720 ext/mbstring/libmbfl/filters/mbfilter_cp5022x.c:281: bad if test
 [2016-07-20 11:34 UTC] davey@php.net
Automatic comment on behalf of yohgaki
Revision: http://git.php.net/?p=php-src.git;a=commit;h=dc23f1f38f649f9a42ebd70e7301462779f82935
Log: Fixed bug #65720 ext/mbstring/libmbfl/filters/mbfilter_cp5022x.c:281: bad if test
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Feb 24 04:01:28 2024 UTC