php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65700 Sending USR2 (reload) to master process kills it
Submitted: 2013-09-18 16:36 UTC Modified: 2013-09-18 19:39 UTC
From: baohx2000 at gmail dot com Assigned:
Status: Not a bug Package: FPM related
PHP Version: 5.5.3 OS: Ubuntu 12.04
Private report: No CVE-ID: None
 [2013-09-18 16:36 UTC] baohx2000 at gmail dot com
Description:
------------
Start php-fpm process with a pool.
Get pid of master process
kill -USR2 [pid]

Expected: master sends reload signal to all children (essentially a graceful 
restart).

Actual: master process dies.  No output.  Nothing logged.  Child processes 
orphaned.

Test script:
---------------
Modules loaded:
[PHP Modules]
bcmath
bz2
calendar
Core
ctype
curl
date
dba
dom
ereg
exif
fileinfo
filter
ftp
gd
gearman
gettext
hash
iconv
json
libphonenumberphp
libxml
mbstring
mcrypt
memcache
memcached
mhash
mongo
mysql
mysqli
OAuth
openssl
pcntl
pcre
PDO
pdo_mysql
Phar
posix
redis
Reflection
session
shmop
SimpleXML
soap
sockets
SPL
standard
sysvmsg
sysvsem
sysvshm
tidy
tokenizer
wddx
xml
xmlreader
xmlwriter
Zend OPcache
zip
zlib

[Zend Modules]
Zend OPcache

Expected result:
----------------
master sends reload signal to all children (essentially a graceful restart).

Actual result:
--------------
master process dies.  No output.  Nothing logged.  Child processes orphaned.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-09-18 16:42 UTC] baohx2000 at gmail dot com
-Status: Open +Status: Closed
 [2013-09-18 16:42 UTC] baohx2000 at gmail dot com
Disregard, should have been using SIGUSR2 instead of USR2.
 [2013-09-18 19:39 UTC] rasmus@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC