php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65689 PDO_Firebird memory leaks when using exec()
Submitted: 2013-09-17 11:23 UTC Modified: 2016-12-26 11:04 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: slavb18 at gmail dot com Assigned: mariuz
Status: Closed Package: PDO Firebird
PHP Version: 5.4.19 OS: any
Private report: No CVE-ID:
 [2013-09-17 11:23 UTC] slavb18 at gmail dot com
Description:
------------
function firebird_handle_doer calls firebird_alloc_prepare_stmt 
and should call isc_dsql_free_statement


Patches

php5-bug65689.patch (last revision 2013-09-18 05:18 UTC) by slavb18 at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-09-17 21:46 UTC] felipe@php.net
-Status: Open +Status: Feedback
 [2013-09-17 21:46 UTC] felipe@php.net
Can you include a valgrind log of memory leak for futher analysis?
 [2013-09-18 05:22 UTC] slavb18 at gmail dot com
memory leaks at firebird side, noticeable with persistent connects (process size grows constantly)
I added isc_dsql_free_statement (see patch), and now is ok
 [2013-10-15 11:54 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2013-10-15 12:03 UTC] slavb18 at gmail dot com
don't know why it is marked as "no feedback", but I actaully answered and supplied a patch
 [2013-10-15 17:09 UTC] nikic@php.net
-Status: No Feedback +Status: Open
 [2013-10-15 17:09 UTC] nikic@php.net
@slavb: That was an automated status change. I reverted it back to Open :)
 [2013-11-30 20:12 UTC] felipe@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: mariuz
 [2014-01-01 12:30 UTC] felipe@php.net
-Package: PDO related +Package: PDO Firebird
 [2016-12-26 11:04 UTC] nikic@php.net
-Status: Assigned +Status: Closed
 [2016-12-26 11:04 UTC] nikic@php.net
Resolved by PR https://github.com/php/php-src/pull/2253.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Jan 22 10:01:50 2017 UTC