php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6567 unable to run any php in solaris 8
Submitted: 2000-09-06 01:42 UTC Modified: 2000-10-02 23:09 UTC
From: billie at i-cable dot com Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.2 OS: solaris 8
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: billie at i-cable dot com
New email:
PHP Version: OS:

 

 [2000-09-06 01:42 UTC] billie at i-cable dot com
i compiled php3 and php4 in solaris 8 with this parameters:
--with-mysql=/usr/local/mysql
--with-gd=/usr/local
--with-apxs=/usr/local/apache/bin/apxs
--enable-versioning
--enable-track-vars
--with-xml
then it gives "libphp3.so" and "libphp4.so" respectively. this is fine. but when i start httpd of apache, it says it's unable to start because libphp3.so or libphp4.so has symbolic reference error. 
note: my apache1.3.12 was compiled with DSO support and SSL.

if i copied working libphp3.so or libphp4.so from a solaris 7 (i successfully run it on solaris 7), it works. but the info is of course recorded those compiled on solaris 7 only. 
so, is there any document or successful examples to compile php on solaris 8?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-09-06 05:32 UTC] sniper@php.net
Are you using  gcc  ? 
Please include the whole error text here.

--Jani

p.s .I have working Apache1.3.12+php4.0.3-dev compiled on solaris 8
using gcc-2.95.2 and with almost same parameters as you.
I don't try to run both php3 and php4 concurrently so I have
left that --enable-versioning out.  And we don't use SSL in that
system.


 [2000-09-08 13:50 UTC] billie at i-cable dot com
here's the parameters to compile apache:
./configure --prefix=/usr/local/apache --enable-shared=max \
--enable-module=ssl --enable-module=most

here's the parameters to compile php3:
./configure --with-mysql=/usr/local/mysql \
--with-apxs=/usr/local/apache/bin/apxs \
--with-gd=/usr/local --enable-versioning --enable-track-vars --with-xml

here's the log after i compiled php3 successfully and run apache:
Syntax error on line 238 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp3.so into server: ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: file /usr/local/apache/libexec/libphp3.so: symbol mysql_free_result: referenced symbol not found
/usr/local/apache/bin/apachectl start: httpd could not be started

i am using DSO, but the libphp3.so is never working. the same to php3 and php4.

 [2000-09-08 19:50 UTC] sniper@php.net
Use /usr/local only as path in --with-mysql.

And if that doesn't help try also adding /usr/local/mysql/lib
into LD_LIBRARY_PATH environment variable

--Jani

 [2000-10-02 23:09 UTC] sniper@php.net
No feedback. 

--Jani
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Oct 22 00:01:28 2019 UTC