php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65619 FPM access log has invalid date and duration with Symfony
Submitted: 2013-09-04 19:54 UTC Modified: 2013-09-04 20:04 UTC
From: php at lavoie dot sl Assigned:
Status: Closed Package: FPM related
PHP Version: 5.4.19 OS: Ubuntu 12.10 Quantal
Private report: No CVE-ID: None
 [2013-09-04 19:54 UTC] php at lavoie dot sl
Description:
------------
I am hosting several PHP platforms (Wordpress, Drupal, Symfony and custom) and I 
am trying to activate access logs with PHP FPM.

Problem is, for all my Symfony installations, the request time (%t) is epoch and 
the duration (%d) and WAY off.

Now, I haven’t found what Symfony is doing is particular, but this should not 
happen in the first place.

I tried with PHP 5.4.6-1ubuntu1.3 and PHP 5.4.19-1+debphp.org~quantal+3

PHPInfo: http://web4.hosting.wemakecustom.com/phpinfo.php

Thank you very much !


Test script:
---------------
access.format = "%{%Y-%m-%d %H:%M:%S}t %{HTTP_HOST}e %m \"%r%Q%q\" %s \"%f\" %{mili}d %{kilo}M %C%%"

Expected result:
----------------
2013-09-04 15:39:05 www.example.com GET "/index.php" 200 
"/var/www/example.com/htdocs/index.php" 428.669 9984 76.98%

Actual result:
--------------
1969-12-31 19:00:00 www.example2.com GET "/app.php" 302 
"/var/www/example2.com/htdocs/app.php" 441483112.485 3328 0.00%

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-09-04 20:00 UTC] php at lavoie dot sl
I also opened a bug in Symfony: https://github.com/symfony/symfony/issues/8931
 [2013-09-04 20:04 UTC] php at lavoie dot sl
-Status: Open +Status: Closed
 [2013-09-04 20:04 UTC] php at lavoie dot sl
Sorry about that, duplicate:
https://bugs.php.net/bug.php?id=62382
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jul 03 18:03:33 2022 UTC