php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65587 When PHP was upgraded from 5.2 to 5.4,then the bug will comes out
Submitted: 2013-08-30 06:14 UTC Modified: 2013-08-30 12:12 UTC
From: xiche at adobe dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: 5.4.19 OS: Linux
Private report: No CVE-ID: None
 [2013-08-30 06:14 UTC] xiche at adobe dot com
Description:
------------
---
From manual page: http://www.php.net/function.strstr#refsect1-function.strstr-description
---
When PHP was upgraded from 5.2 to 5.4,then the warning message will comes out:

PHP Warning:  strstr() expects parameter 1 to be string, array given in - on line 1


Patches

PHPWarning (last revision 2013-08-30 06:15 UTC by xiche at adobe dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-08-30 06:47 UTC] requinix@php.net
-Status: Open +Status: Feedback
 [2013-08-30 06:47 UTC] requinix@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.


 [2013-08-30 12:12 UTC] johannes@php.net
-Status: Feedback +Status: Not a bug
 [2013-08-30 12:12 UTC] johannes@php.net
In the old version an array was silently converted to a string "Array" which makes little sense. PHP no warns when this would happen. This is a bug in your code we're warning you about.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jan 23 04:01:24 2020 UTC