php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65539 Library detection
Submitted: 2013-08-24 15:21 UTC Modified: 2013-09-06 11:55 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: remi@php.net Assigned: reeze
Status: Closed Package: leveldb (PECL)
PHP Version: 5.5.3 OS: GNU/Linux
Private report: No CVE-ID:
 [2013-08-24 15:21 UTC] remi@php.net
Description:
------------
The current config.m4 provided doesn't work because it doesn't honors
- PHP_LIBDIR (which can be lib ou lib64)
- SHLIB_SUFFIX_NAME (which can is .so on Linux)

Attached patch fix this.


Patches

config.patch (last revision 2013-08-24 15:21 UTC) by remi)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-09-06 11:55 UTC] reeze@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: reeze
 [2013-09-06 11:55 UTC] reeze@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

Thanks!
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC