php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #65520 Missing Multibyte String (mbstring) directive documentation
Submitted: 2013-08-22 18:08 UTC Modified: 2014-01-28 02:46 UTC
From: cevfora at elitemail dot org Assigned: yohgaki (profile)
Status: Closed Package: mbstring related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2013-08-22 18:08 UTC] cevfora at elitemail dot org
Description:
------------

a) The page titled "Runtime Configuration" for extension "Multibyte String" 

http://www.php.net/manual/en/mbstring.configuration.php

is missing a short explanation of the directive mbstring.script_encoding.

b) The same page lacks any documentation of directive mbstring.http_output_conv_mimetypes.

c) Both of these directives require links from the page titled "List of php.ini directives" at

http://php.net/manual/en/ini.list.php

where the directives are listed as follows.

mbstring.script_encoding 	NULL 	PHP_INI_ALL 	Available since PHP 4.3.0.
mbstring.http_output_conv_mimetypes 	"^(text/|application/xhtml\+xml)" 	PHP_INI_ALL 	Available since PHP 5.3.0.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-03 05:30 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 [2013-10-03 05:30 UTC] krakjoe@php.net
The list of ini directives is not meant to function as a sitemap for the manual, it is meant to provide an exhaustive list of options, but does not necessarily have to link to a manual page.
 [2014-01-27 03:06 UTC] yohgaki@php.net
-Status: Not a bug +Status: Open -Assigned To: +Assigned To: yohgaki
 [2014-01-28 02:46 UTC] yohgaki@php.net
-Status: Assigned +Status: Closed
 [2014-01-28 02:46 UTC] yohgaki@php.net
Doc is updated
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 15 02:01:28 2024 UTC