php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #65518 Missing documentation for mail.force_extra_parameters directive
Submitted: 2013-08-22 17:53 UTC Modified: 2014-11-17 20:34 UTC
From: cevfora at elitemail dot org Assigned: salathe (profile)
Status: Closed Package: Mail related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2013-08-22 17:53 UTC] cevfora at elitemail dot org
Description:
------------
a) Documentation for the directive mail.force_extra_parameters introduced in PHP 5 is missing from the page titled "Runtime Configuration" for package Mail.

http://www.php.net/manual/en/mail.configuration.php

b) Runtime configuration directive mail.force_extra_parameters on the page titled "List of php.ini directives"

http://php.net/manual/en/ini.list.php

is missing a link to the page titled "Runtime Configuration" for package Mail where the documentation should appear.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-08-22 17:55 UTC] johannes@php.net
-Type: Bug +Type: Documentation Problem
 [2013-10-03 05:51 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 [2013-10-03 05:51 UTC] krakjoe@php.net
The INI list is not meant to function as a sitemap, it is meant to provide an exhaustive list, but does not necessarily have to link to a manual page.
 [2014-06-23 11:44 UTC] tyrael@php.net
-Status: Not a bug +Status: Re-Opened
 [2014-06-23 11:44 UTC] tyrael@php.net
I disagree, while the missing link itself is not a problem, but the ini entry should be in http://www.php.net/manual/en/mail.configuration.php#ini.mail.log
and currently the only place where we describe what this ini setting does is in the migration guide:
http://www.php.net//manual/en/migration5.newconf.php
 [2014-11-17 20:33 UTC] salathe@php.net
Automatic comment from SVN on behalf of salathe
Revision: http://svn.php.net/viewvc/?view=revision&revision=335188
Log: document mail.force_extra_parameters (doc bug #65518)
 [2014-11-17 20:33 UTC] salathe@php.net
-Status: Re-Opened +Status: Closed -Assigned To: +Assigned To: salathe
 [2014-11-17 20:33 UTC] salathe@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 [2014-11-17 20:34 UTC] salathe@php.net
Whoops, wrong "quick fix" message...

This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Dec 04 01:04:24 2021 UTC