php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #65516 Missisng documentation links for ldap.base_dn and ldap.max_links
Submitted: 2013-08-22 17:15 UTC Modified: 2017-01-09 17:18 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: cevfora at elitemail dot org Assigned: jeanseb (profile)
Status: Closed Package: LDAP related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2013-08-22 17:15 UTC] cevfora at elitemail dot org
Description:
------------

Runtime configuration directives ldap.base_dn and ldap.max_links for extension LDAP 

ldap.base_dn 	NULL 	PHP_INI_ALL 	Removed in PHP 4.2.0.
ldap.max_links 	"-1" 	PHP_INI_SYSTEM 	 

on the page titled "List of php.ini directives"

http://php.net/manual/en/ini.list.php

are missing links to documentation on the page titled "Runtime Configuration" for package LDAP.

http://www.php.net/manual/en/ldap.configuration.php

Moreover, while the removed directive ldap.base_dn is documented on page ini.list.php, it is not mentioned on page ldap.configuration.php.





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-09-02 20:53 UTC] jeanseb@php.net
-Assigned To: +Assigned To: jeanseb
 [2013-09-02 20:53 UTC] jeanseb@php.net
Hi,

Thanks for the feedback.

ldap.base_dn has been removed for years thus I don't think it deserve more documentation but I will ask for comment on the doc mailing list

ldap.max_links seems to be an undocumented param, I will write some words on it.
 [2017-01-09 17:18 UTC] heiglandreas@php.net
-Status: Assigned +Status: Closed
 [2017-01-09 17:18 UTC] heiglandreas@php.net
As this seems already to be fixed I'm closing this issue
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 09:05:54 2022 UTC