php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #65512 Incorrect documentation of GeoIP configuration directives
Submitted: 2013-08-22 16:33 UTC Modified: 2013-10-03 05:43 UTC
From: cevfora at elitemail dot org Assigned:
Status: Not a bug Package: geoip (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2013-08-22 16:33 UTC] cevfora at elitemail dot org
Description:
------------
Documentation for GeoIP the page titled "Runtime Configuration"

http://www.php.net/manual/en/geoip.configuration.php

states

"This extension has no configuration directives defined in php.ini."

However, the page titled "List of php.ini directives" 

http://php.net/manual/en/ini.list.php

includes directives

geoip.custom_directory 	NULL 	PHP_INI_ALL 	Available since geoip 1.0.1.
geoip.database_standard 	"GeoIP.dat" 	PHP_INI_ALL 	Removed in geoip 1.0.1.

Links should be provided on this page to the GeoIP documentation which should include description of the functionality for the geoip.custom_directory directive.






Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-03 05:43 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 [2013-10-03 05:43 UTC] krakjoe@php.net
The list of INI options is not meant to function as a sitemap, it is meant to provide an exhaustive list, but does not necessarily have to link to manual pages.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Jan 21 06:01:23 2020 UTC