php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #65477 fileDelete function
Submitted: 2013-08-19 11:25 UTC Modified: 2021-03-31 10:33 UTC
From: john at qeweb dot org Assigned: cmb (profile)
Status: Wont fix Package: Filesystem function related
PHP Version: Irrelevant OS: all
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2013-08-19 11:25 UTC] john at qeweb dot org
Description:
------------
---
From manual page: http://www.php.net/function.delete
---

Please can we have an easier to remember file delete function as a synonym for 'unlink'.

Not coming from a C or Unix background, I have to look it up every time - and the fact that you have put up a page suggests this is common.

Test script:
---------------
This is not a bug report


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-03-31 10:33 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2021-03-31 10:33 UTC] cmb@php.net
If you need the function occassionally, looking it up in the
manual shouldn't be a problem.  If you need it often, you will get
used to it.  And finally, you can define the alias in userland and
add it to auto_prepend_file.

If you feel strongly that this alias should be introduced, please
pursue the RFC process[1].

[1] <https://wiki.php.net/rfc/howto>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue May 11 08:01:24 2021 UTC